22.07.2017, 15:44 [+3 UTC]
в нашей команде: 2 066 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
21.07.2017, 11:30

Последний вопрос:
20.07.2017, 15:47

Последний ответ:
21.07.2017, 15:17

Последняя рассылка:
22.07.2017, 14:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
17.02.2012, 20:31 »
Николай Мироненко
Спасибо Вам большое за подробный ответ))) [вопрос № 185456, ответ № 269996]
11.12.2009, 17:49 »
Sergeva
Спасибо огромное, все работает классно! [вопрос № 175140, ответ № 257610]
26.09.2010, 16:39 »
Sergey V. Gornostaev
Спасибо! Оно одно к одному: что страховая компания, что автосалон. Это я понял позже (как и многие другие наверно). [вопрос № 180036, ответ № 263194]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 136665
Раздел: [неизвестная рассылка]
Автор вопроса: Asteroid
Отправлена: 13.05.2008, 17:10
Поступило ответов: 2

7,7 Ситация: есть справочник ТМЦ в нем есть реквизиты которые являются элементами другого справочника "ткани" . Вопрос: как запретить человеку выбырать элемент справочника Тмц в доки если в нем есть реквизиты (элнменты справочника Ткани) которые помечены на удалении.
Тоесть нужно чтобы система проверяла и выкидывала сообщение.

Состояние: Консультация закрыта

Ответ # 223348 от Кулевский Сергей Владимирович

Здравствуйте, Asteroid!
Попробуйте так:

Если Номенклатура.Ткани.ПометкаНаУдаление Тогда
Сообщить("Элемент выбирать нельзя");
Возврат
КонецЕсли;

Номенклатура - ссылка на элемент справочника ТМЦ
Ткани - имя реквизита на справочник Ткани в элементе "Номенклатура"


Консультировал: Кулевский Сергей Владимирович
Дата отправки: 13.05.2008, 17:36

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 223356 от Maximush

Здравствуйте, Asteroid!

Допустим в документе есть реквизит "ТМЦ" при выборе которого и надо контролировать не входят ли в это ТМЦ помеченные на удаление ткани.
Тогда в форме документа на реквизит ТМЦ вешаем процедуру ПриВыбореТМЦ() (Свойства реквизита, Закладка "Дополнительно", поле формула).
В модуль формы документа добавляем код:
//------------
Процедура ПриВыбореТМЦ()
//здесь проверяем все ваши "реквизиты которые являются элементами другого справочника "ткани" "
Если (ТМЦ.Ткань1.ПометкаУдаления()=1)
или (ТМЦ.Ткань2.ПометкаУдаления() =1)
тогда
Сообщить("Выкидываемое сообщение"); //матюгаемся
ТМЦ = ""; //очищаем значение
КонецЕсли;
КонецПроцедуры
//------------
Если на реквизите уже висит какая-то процедура или функция - то дописываем данный кусок в эту функцию.

Извините, если слишком подробно, я только что от клиента smile


Консультировал: Maximush
Дата отправки: 13.05.2008, 18:55

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13193 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн