24.09.2017, 20:24 [+3 UTC]
в нашей команде: 2 128 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
24.09.2017, 16:39

Последний вопрос:
24.09.2017, 14:40

Последний ответ:
24.09.2017, 15:05

Последняя рассылка:
24.09.2017, 14:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
27.04.2011, 22:10 »
Ameno
Быстро, что было важно и очень четко! [вопрос № 182962, ответ № 266856]
24.06.2010, 10:23 »
Adsorores
Спасибо за программу! [вопрос № 179212, ответ № 262260]
09.07.2010, 11:08 »
Викол Василий
Спасибо огромное за ответ!!!!!!!!!!! [вопрос № 179431, ответ № 262452]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 136665
Раздел: [неизвестная рассылка]
Автор вопроса: Asteroid
Отправлена: 13.05.2008, 17:10
Поступило ответов: 2

7,7 Ситация: есть справочник ТМЦ в нем есть реквизиты которые являются элементами другого справочника "ткани" . Вопрос: как запретить человеку выбырать элемент справочника Тмц в доки если в нем есть реквизиты (элнменты справочника Ткани) которые помечены на удалении.
Тоесть нужно чтобы система проверяла и выкидывала сообщение.

Состояние: Консультация закрыта

Ответ # 223348 от Кулевский Сергей Владимирович

Здравствуйте, Asteroid!
Попробуйте так:

Если Номенклатура.Ткани.ПометкаНаУдаление Тогда
Сообщить("Элемент выбирать нельзя");
Возврат
КонецЕсли;

Номенклатура - ссылка на элемент справочника ТМЦ
Ткани - имя реквизита на справочник Ткани в элементе "Номенклатура"


Консультировал: Кулевский Сергей Владимирович
Дата отправки: 13.05.2008, 17:36

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 223356 от Maximush

Здравствуйте, Asteroid!

Допустим в документе есть реквизит "ТМЦ" при выборе которого и надо контролировать не входят ли в это ТМЦ помеченные на удаление ткани.
Тогда в форме документа на реквизит ТМЦ вешаем процедуру ПриВыбореТМЦ() (Свойства реквизита, Закладка "Дополнительно", поле формула).
В модуль формы документа добавляем код:
//------------
Процедура ПриВыбореТМЦ()
//здесь проверяем все ваши "реквизиты которые являются элементами другого справочника "ткани" "
Если (ТМЦ.Ткань1.ПометкаУдаления()=1)
или (ТМЦ.Ткань2.ПометкаУдаления() =1)
тогда
Сообщить("Выкидываемое сообщение"); //матюгаемся
ТМЦ = ""; //очищаем значение
КонецЕсли;
КонецПроцедуры
//------------
Если на реквизите уже висит какая-то процедура или функция - то дописываем данный кусок в эту функцию.

Извините, если слишком подробно, я только что от клиента smile


Консультировал: Maximush
Дата отправки: 13.05.2008, 18:55

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13933 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн