Лидеры рейтинга

ID: 226425

Konstantin Shvetski

Мастер-Эксперт

1003

Россия, Северодвинск


ID: 259041

Алексеев Владимир Николаевич

Мастер-Эксперт

643

Россия, пос. Теплоозёрск, ЕАО


ID: 400669

epimkin

Профессионал

364


ID: 401284

Михаил Александров

Академик

351

Россия, Санкт-Петербург


ID: 137394

Megaloman

Мастер-Эксперт

257

Беларусь, Гомель


ID: 400484

solowey

Профессор

95


ID: 401888

puporev

Профессор

52

Россия, Пермский край


8.1.6

02.01.2021

JS: 2.2.2
CSS: 4.2.0
jQuery: 3.5.1


 

Установка, настройка и работа в пакете Microsoft Office.

Администратор раздела: Megaloman (Мастер-Эксперт)


Megaloman
Статус: Мастер-Эксперт
Рейтинг: 257
Зенченко Константин Николаевич
Статус: Старший модератор
Рейтинг: 243
solowey
Статус: Профессор
Рейтинг: 95
 

Перейти к консультации №:
 

Консультация онлайн # 199840
Раздел: • Пакет MSOffice
Автор вопроса: alekseyslobodyanyuk20003 (Посетитель)
Дата: 10.12.2020, 20:13
Поступило ответов: 1

Здравствуйте! У меня возникли сложности с таким вопросом: Вычислить (без использования компьютера) следующую формулу Ехсе1, сопровождая ответ промежуточными расчетами:
-ЕСЛИ(НЕ(И(А1<>В1;В1>С1)); ИЛИ(А1>=В1+1; ЛОЖЬ); ЕСЛИ(А1<С1; А1-В1;А1+В1))
Содержимое ячеек: А1=1; B1=3, С1= 2 .

Последнее редактирование 11.12.2020, 11:44 Сергей Фрост (Управляющий)

Состояние: Консультация закрыта

Ответ # 280477 от Megaloman (Мастер-Эксперт)

Здравствуйте, alekseyslobodyanyuk20003!

Цитата: Описание функции ЕСЛИ в справке по функциям Excel
ЕСЛИ(лог_выражение, [значение_если_истина], [значение_если_ложь])
Для Вашей задачи:
лог_выражение=		НЕ(И(A1<>B1;B1>C1));
значение_если_истина=	ИЛИ(А1>=В1+1;ЛОЖЬ);
значение_если_ложь=	ЕСЛИ(A1<C1; A1-B1;A1+B1);


А1=1; B1=3, С1= 2;

Распишем лог_выражение:
(A1<>B1)=(1<>3)=ИСТИНА;
(B1>C1)=(3>2)=ИСТИНА;
И(А1<>В1;В1>С1)=И(ИСТИНА;ИСТИНА;)=ИСТИНА;
лог_выражение=НЕ(И(A1<>B1;B1>C1))=НЕ(ИСТИНА)=ЛОЖЬ;

Распишем значение_если_истина (в данном случае это имеет справочный характер, так как лог_выражение= ЛОЖЬ и значение функции ЕСЛИ будет определяться выражением значение_если_ложь.
(А1>=В1+1)=(1>=4)=ЛОЖЬ;
значение_если_истина=ИЛИ(А1>=В1+1;ЛОЖЬ)=ИЛИ(ЛОЖЬ;ЛОЖЬ)=ЛОЖЬ;

Распишем значение_если_ложь.
(A1<C1)=(1<2)=ИСТИНА;
(A1-B1)=(1-3)=-2;
(A1+B1)=(1+3)=4; В данном контексте это несущественно, так как для этой функции ЕСЛИ это выражение не вычисляется.
значение_если_ложь=ЕСЛИ(A1<C1;A1-B1;A1+B1)=ЕСЛИ(ИСТИНА;-2;4)=-2;

Итак:
-ЕСЛИ(НЕ(И(A1<>B1;B1>C1)); ИЛИ(A1>=B1+1; ЛОЖЬ); ЕСЛИ(A1<C1; A1-B1;A1+B1))=
-ЕСЛИ(ЛОЖЬ; ЛОЖЬ; -2)=2;


Консультировал: Megaloman (Мастер-Эксперт)
Дата отправки: 11.12.2020, 17:14

5
нет комментария
-----
Дата оценки: 11.12.2020, 20:55

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 199840

Megaloman

Мастер-Эксперт

ID: 137394

1

= общий = |  10.12.2020, 21:21 |  цитировать |  профиль |  личное сообщение
alekseyslobodyanyuk20003:

Вам скорее всего надо правильное оформление, записанное в виде мат. выражения.
Формально, как сформулирована задача, то вот рассуждения:

А1=1; B1=3, С1= 2;

Описание функции ЕСЛИ в Excel:
ЕСЛИ(лог_выражение, [значение_если_истина], [значение_если_ложь])

лог_выражение= НЕ(И(A1<>B1;B1>C1));
значение_если_истина= ИЛИ(А1>=В1+1;ЛОЖЬ);
значение_если_ложь= ЕСЛИ(A1<C1; A1-B1;A1+B1);

(A1<>B1)=(1<>3)=ИСТИНА;
(B1>C1)=(3>2)=ИСТИНА;
И(А1<>В1;В1>С1)=И(ИСТИНА;ИСТИНА;)=ИСТИНА;
лог_выражение=НЕ(И(A1<>B1;B1>C1))=НЕ(ИСТИНА)=ЛОЖЬ;


(A1<C1)=(1<2)=ИСТИНА;
(A1-B1)=(1-3)=-2;
значение_если_ложь=ЕСЛИ(A1<C1;A1-B1;A1+B1)=ЕСЛИ(ИСТИНА;;-2;A1+B1)=-2;

-ЕСЛИ(НЕ(И(A1<>B1;B1>C1)); ИЛИ(A1>=B1+1; ЛОЖЬ); ЕСЛИ(A1<C1; A1-B1;A1+B1))=
=-ЕСЛИ(ЛОЖЬ; ИЛИ(A1>=B1+1; ЛОЖЬ); -2)=2;

Последнее редактирование 10.12.2020, 21:25 Megaloman (Мастер-Эксперт)

=====
Нет времени на медленные танцы

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.