Родились сегодня:
vladymyrlem
antonovich


Лидеры рейтинга

ID: 226425

Konstantin Shvetski

Модератор

740

Россия, Северодвинск


ID: 259041

Алексеев Владимир Николаевич

Мастер-Эксперт

322

Россия, пос. Теплоозёрск, ЕАО


ID: 401284

Михаил Александров

Академик

277

Россия, Санкт-Петербург


ID: 325460

CradleA

Мастер-Эксперт

210

Беларусь, Минск


ID: 137394

Megaloman

Мастер-Эксперт

129

Беларусь, Гомель


ID: 400815

alexleonsm

6-й класс

129


ID: 400669

epimkin

Профессионал

119


8.8.15

09.05.2021

JS: 2.8.21
CSS: 4.5.5
jQuery: 3.6.0
DataForLocalStorage: 2021-05-13 03:16:01-standard


[неизвестная рассылка]

Администратор раздела: [неизвестный]

Консультация онлайн # 159740

Раздел: [неизвестная рассылка]
Автор вопроса: Igor Maevsky
Дата: 06.02.2009, 10:54 Консультация закрыта
Поступило ответов: 1

Добрый день.
Проблема с изменением наименования для элементов справочника. Так как я не силён в программировании 1С, подскажите, пожалуйста, как исправить ошибку.
Имеется следующий код:

СпрКонтр = СоздатьОбъект("Справочники.Контрагенты);
СпрДог = СоздатьОбъект("Справочники.Договоры);

СпрКонтр.ИспользоватьРодителя(ВыбКонтрагент, 1);
СпрКонтр.ВыбратьЭлементы(1);
Пока СпрКонтр.ПолучитьЭлемент() = 1 Цикл
Если спрКонтр.ЭтоГруппа() = 0 Тогда
СпрДог.ИспользоватьВладельца(СпрКонтр.ТекущийЭлемент());
СпрДог.ВыбратьЭлементы();
Пока СпрДог.ПолучитьЭлемент() = 1 Цикл
СпрДог.Наименование = "ТО " + СокрЛП(СпрДог.НомерДоговора);
СпрДог.Записать();
КонецЦикла;
КонецЕсли;
КонецЦикла;


Ошибка.
СпрДог.Наименование = "ТО " + СокрЛП(СпрДог.НомерДоговора);
{D:\BASE1C\1.ERT(23)}: Изменено Наименование! Может быть нарушена последовательность выборки!


Спасибо.

Ответ # 243017 от Дмитрий Сташенко
Здравствуйте, Igor Maevsky!

Используйте при выборке элементов порядок кодов.

Приложение:


Дмитрий Сташенко

Посетитель
06.02.2009, 11:08
Мини-форум консультации # 159740
неизвестный

1

= общий =    06.02.2009, 11:12

Спасибо.

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Лучшие эксперты раздела