21.07.2019, 08:31 [+3 UTC]
в нашей команде: 3 751 чел. | участники онлайн: 2 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.77 (31.05.2019)
JS-v.1.34 | CSS-v.3.35

Общие новости:
28.04.2019, 09:13

Форум:
18.07.2019, 12:26

Последний вопрос:
20.07.2019, 17:15
Всего: 149945

Последний ответ:
21.07.2019, 08:29
Всего: 258715

Последняя рассылка:
21.07.2019, 01:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
18.09.2009, 10:59 »
Rem88-72
Большое спасибо за разъяснение данного вопроса! Всё очень даже ценно! [вопрос № 172285, ответ № 254323]
17.05.2010, 11:20 »
Юдин Евгений Сергеевич
отлично продумано спасибо! [вопрос № 178381, ответ № 261432]
11.02.2019, 10:32 »
dar777
Это самое лучшее решение! [вопрос № 194662, ответ № 277450]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 67543
Раздел: [неизвестная рассылка]
Автор вопроса: Darina
Отправлена: 18.12.2006, 15:59
Поступило ответов: 5

Привет всем экспертам! Подскажите пожалуйста кто может: как для одного вида документа организовать две нумерации (напр.одна РасходнаяНакладная на два магазина).Я сделала тип номера текстовый и завела для 1 магазина К-001, а для 2 - В-001. Для вводе нового документа появляется К-002, а для второго надо смотреть, какой номер был последним. Нельзя как то решить эту проблему?

Состояние: Консультация закрыта

Ответ # 132297 от Warior

Здравствуйте, Darina!
Попробуйте при изменении магазина выполнять эту процедуру
Процедура УстановитьНомерДок()
Перем Стр;
Стр = "";
Если Склад = Магазин1
Стр = "К";
Иначе
Стр = "В";
КонецЕсли;
Конт.УстановитьНовыйНомер(СокрЛП(Стр));
КонецПроцедуры
Удачи


Консультировал: Warior
Дата отправки: 18.12.2006, 17:37

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 132300 от Gl0betrotter

Здравствуйте, Darina!

Можно, и достаточно спокойно:
в форме документа в поле выбора реквизита "Контрагент" добавить, например, процедуру ПриВыбореКонтрагента()
В модуле формы документа в процедуре ПриВыбореКонтрагента() добавим строки
Если Контрагент = Магазин1 Тогда
УстановитьНовыйНомер("К-");
ИначеЕсли Контрагент = Магазин2 Тогда
УстановитьНовыйНомер("В-");
КонецЕсли;

Т.о. мы не анализируем какой номер был последним, а "разруливаем" ситуацию при помощи префикса автонумерации (в нашем случае "К-" и "В-").
Думаю, в условии необходимо также предусмотреть обработку исключительных ситуаций, например, когда Контрагент не указан или указаны не Магазин1 и Магазин2.

Удачи!


Консультировал: Gl0betrotter
Дата отправки: 18.12.2006, 17:42

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 132302 от Strawberry

Здравствуйте, Darina!
Зачем самому нумеровать ???
доставьте это удовольстие компьютеру. Присваивайте префикс документу в зависимости от склада (магазина)
УстановитьНовыйНомер(<?>);
Синтаксис:
УстановитьНовыйНомер(<Префикс>)
Назначение:
Установить новый номер документа с заданным префиксом.
Параметры:
<Префикс> - строка с префиксом номера документа.


Консультировал: Strawberry
Дата отправки: 18.12.2006, 17:50

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 132380 от Сергей

Здравствуйте, Darina!
мне кажется в этом случае лучше сделать следующее:
1 вариант. добавить еще один реквизит в шапку (тип перечисление), в котором можно задать ваш магазин (К - первый магазин, В - второй магазин).
и тогда нумерация будет сквозная, а по букве можно определить магазин.
2 вариант. Добавить через копирование документ РасходнаяНакладная, только назвать по другому, и тогда у вас будет два типа документа РасходнаяНакладная, каждый со своей нумерацией.
Будут вопросы пишите.


Консультировал: Сергей
Дата отправки: 19.12.2006, 09:16

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 132595 от Гребиников Павел Генадьевич

Здравствуйте, Darina!
Если не важны номера документов, вы можете для каждого магазина завести реквизит "префикс" и при выборе магазина префикс будет автоматически прибавляться к номеру документа.
получится примерно так
К-001
К-002
В-003
К-004
Думаю, смысл понятен.
Ну а если вам надо, чтоб у вас было и К-002 и В-002 тогда используйте реквизит для тогоже справочника магазин чтото типа номерпоследнего документа.


Консультировал: Гребиников Павел Генадьевич
Дата отправки: 20.12.2006, 08:37

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 2.57804 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.77 от 31.05.2019
Версия JS: 1.34 | Версия CSS: 3.35