27.05.2019, 05:34 [+3 UTC]
в нашей команде: 3 648 чел. | участники онлайн: 1 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.75 (18.05.2019)
JS-v.1.33 | CSS-v.3.35

Общие новости:
28.04.2019, 09:13

Форум:
25.05.2019, 11:20

Последний вопрос:
26.05.2019, 22:05
Всего: 149702

Последний ответ:
26.05.2019, 16:58
Всего: 258528

Последняя рассылка:
26.05.2019, 23:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
02.07.2010, 11:24 »
Dimon4ik
Большое спасибо. Помогло отключение отдельных программ в автозагрузке. Таких как StarDock ObjectDock, DaemonTools, Mail.ru агент и т.д. Выявить какая именно программа вызывала торможение не удается. Так как при включении любой из них вручную проблема подвисания компьютера не появляется. [вопрос № 179354, ответ № 262381]
18.11.2010, 00:42 »
Лукин Андрей
большое спасибо, все работает =) [вопрос № 180826, ответ № 264153]
22.02.2012, 15:55 »
lamed
Большое спасибо, Андрей Владимирович! С уважением. [вопрос № 185461, ответ № 270023]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66821
Раздел: [неизвестная рассылка]
Автор вопроса: Vlad
Отправлена: 13.12.2006, 14:54
Поступило ответов: 3

Здравствуйте уважаемые эксперты!!!
Подскажите советом как вывести в отчет данные (код модуля см. в приложении).
Задача в том чтобы каждый раз не заходить в Счет и не проверять вводился ли на основании Счета документ Заявка, а вывести в отчет (т.е. в первой колонке Счет, а во второй подчиненный ему документ Заявка. Если вводился то во второй колонке выводится *есть*, если нет то *-*).
Заранее огромное спасибо!

Приложение:

Состояние: Консультация закрыта

Ответ # 131433 от Ovr1970

Здравствуйте, Vlad!
Сделайте проще, в журнале счетов добаьте текстовую колонку, в которую выведите следующую вункцию

Приложение:


Консультировал: Ovr1970
Дата отправки: 13.12.2006, 15:26

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131434 от Игорь К.

Здравствуйте, Vlad!
Попробуйте добавить в запрос строчку (в конец, после группировки)

|Функция Заявка = ЕстьЗаявка(СчетПроиз);

и анализируйте Запрос.Заявка.

Удачи!


Консультировал: Игорь К.
Дата отправки: 13.12.2006, 15:28

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131436 от Warior

Здравствуйте, Vlad!
если речь идет о печатной форме тогда
попробуйте так. (первая колонка = сч, вторая = Заявка (есть или нет))
Функция ЕстьЗаявка(пДок)
лПр="-";
лДок=СоздатьОбъект("Документ.ЗаявкаНаМатериалы");
лДок.ВыбратьПодчиненныеДокументы('01.01.2001',РабочаяДата(),пДок);
Пока лДок.ПолучитьДокумент()=1 Цикл
Если лДок.Проведен()=1 Тогда
лПр="Есть";
КонецЕсли;
КонецЦикла;
Возврат лПр;
КонецФункции

//---------------------------------------------------------------------------------

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса ="
|Период с Дата1 по Дата2;
|СчетПроиз = Документ.СчетПр.ТекущийДокумент;
|Заказчик=Документ.СчетПр.Контрагент;
|Группировка СчетПроиз;
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;


Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка");
Состояние("Заполнение выходной таблицы...");
Пока Запрос.Группировка(1)=1 Цикл
Сч=Запрос.СчетПроиз;
Зак=Запрос.Заказчик;
Заявка=ЕстьЗаявка(Сч);
Таб.ВывестиСекцию("Строка");
КонецЦикла;


Таб.Опции(0);
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Консультировал: Warior
Дата отправки: 13.12.2006, 15:30

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13533 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.75 от 18.05.2019
Версия JS: 1.33 | Версия CSS: 3.35