19.09.2018, 11:12 [+3 UTC]
в нашей команде: 2 971 чел. | участники онлайн: 4 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.50 (13.09.2018)

Общие новости:
13.04.2018, 10:33

Форум:
18.09.2018, 08:51

Последний вопрос:
18.09.2018, 15:34

Последний ответ:
19.09.2018, 08:03

Последняя рассылка:
18.09.2018, 17:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
18.09.2009, 10:56 »
Rem88-72
Отличный ответ на мой вопрос! Весь ответ представленн в полном виде. Огромное спасибо! [вопрос № 172285, ответ № 254321]
17.12.2009, 16:52 »
Николай // Programmator
Выбрал ON, все работает. Спасибо Вам! [вопрос № 175355, ответ № 257846]
26.01.2012, 09:42 »
Вадим Исаев ака sir Henry
Про FAR это Вы мне хорошо напомнили, а то я, честно говоря, об этом уже забыл. [вопрос № 185293, ответ № 269749]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66821
Раздел: [неизвестная рассылка]
Автор вопроса: Vlad
Отправлена: 13.12.2006, 14:54
Поступило ответов: 3

Здравствуйте уважаемые эксперты!!!
Подскажите советом как вывести в отчет данные (код модуля см. в приложении).
Задача в том чтобы каждый раз не заходить в Счет и не проверять вводился ли на основании Счета документ Заявка, а вывести в отчет (т.е. в первой колонке Счет, а во второй подчиненный ему документ Заявка. Если вводился то во второй колонке выводится *есть*, если нет то *-*).
Заранее огромное спасибо!

Приложение:

Состояние: Консультация закрыта

Ответ # 131433 от Ovr1970

Здравствуйте, Vlad!
Сделайте проще, в журнале счетов добаьте текстовую колонку, в которую выведите следующую вункцию

Приложение:


Консультировал: Ovr1970
Дата отправки: 13.12.2006, 15:26

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131434 от Игорь К.

Здравствуйте, Vlad!
Попробуйте добавить в запрос строчку (в конец, после группировки)

|Функция Заявка = ЕстьЗаявка(СчетПроиз);

и анализируйте Запрос.Заявка.

Удачи!


Консультировал: Игорь К.
Дата отправки: 13.12.2006, 15:28

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131436 от Warior

Здравствуйте, Vlad!
если речь идет о печатной форме тогда
попробуйте так. (первая колонка = сч, вторая = Заявка (есть или нет))
Функция ЕстьЗаявка(пДок)
лПр="-";
лДок=СоздатьОбъект("Документ.ЗаявкаНаМатериалы");
лДок.ВыбратьПодчиненныеДокументы('01.01.2001',РабочаяДата(),пДок);
Пока лДок.ПолучитьДокумент()=1 Цикл
Если лДок.Проведен()=1 Тогда
лПр="Есть";
КонецЕсли;
КонецЦикла;
Возврат лПр;
КонецФункции

//---------------------------------------------------------------------------------

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса ="
|Период с Дата1 по Дата2;
|СчетПроиз = Документ.СчетПр.ТекущийДокумент;
|Заказчик=Документ.СчетПр.Контрагент;
|Группировка СчетПроиз;
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;


Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка");
Состояние("Заполнение выходной таблицы...");
Пока Запрос.Группировка(1)=1 Цикл
Сч=Запрос.СчетПроиз;
Зак=Запрос.Заказчик;
Заявка=ЕстьЗаявка(Сч);
Таб.ВывестиСекцию("Строка");
КонецЦикла;


Таб.Опции(0);
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Консультировал: Warior
Дата отправки: 13.12.2006, 15:30

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13851 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.50 от 13.09.2018