22.01.2019, 12:34 [+3 UTC]
в нашей команде: 3 344 чел. | участники онлайн: 5 (рекорд: 20)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.65 (20.01.2019)
JS-v.1.31 | CSS-v.3.35

Общие новости:
01.01.2019, 13:54

Форум:
14.01.2019, 10:08

Последний вопрос:
21.01.2019, 23:17
Всего: 148545

Последний ответ:
22.01.2019, 12:04
Всего: 257629

Последняя рассылка:
22.01.2019, 11:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
24.04.2014, 09:13 »
Пупкин Василий Эдуардович)
Зачет) [вопрос № 187810, ответ № 272732]
21.11.2010, 01:52 »
Мироненко Николай Николаевич
Огромное Вам спасибо за такой хороший ответ smile [вопрос № 180815, ответ № 264206]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66076
Раздел: [неизвестная рассылка]
Автор вопроса: Ирка
Отправлена: 08.12.2006, 10:29
Поступило ответов: 3

Здравствуйте! Подскажите,пожалуйста,можно ли в 1С программно открыть список констант ?

Состояние: Консультация закрыта

Ответ # 130590 от Зайцев Александр

Здравствуйте, Ирка!
Открыть програмно нельзя, но если есть такая необходимость, то можно сделать свою форму, на форму выложить таблицу значений, и заполнить ее крнстантами примерно так:
//ТЗ - таблица значений на форме
Процедура ПриОткрытии()
Для Инд=1 По Метаданные.Константа() Цикл
ТЗ.НоваяСтрока();
ТЗ.Идент=Метаданные.Константа(Инд).Идентификатор;
ТЗ.Комментарий=Метаданные.Константа(Инд).Комментарий;
КонецЦикла;
КонецПроцедуры;
Если не совсем понятно, то пишите в личку - помогу


Консультировал: Зайцев Александр
Дата отправки: 08.12.2006, 10:47

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130594 от BuhCIA

Здравствуйте, Ирка!
Для Инд = 1 По Метаданные.Константа() Цикл
Идент=Метаданные.Константа(Инд).Идентификатор;
Сообщить(Метаданные.Константа(Инд).Идентификатор+"="+Метаданные.Константа(Идент));
КонецЦикла;
Здесь все три варианта обращения: количество констант, константа по номеру, константа по идентификатору. Проверка идентификатора:
Если Метаданные.Константа(Идент).Выбран()=0 Тогда
Сообщить("нет такой константы "+Идент);
КонецЕсли;


Консультировал: BuhCIA
Дата отправки: 08.12.2006, 10:57

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130595 от Gl0betrotter

Здравствуйте, Ирка!

О программном открытии не слышал - предлагаю использовать обработку с таблицей значений, в которую загонять все данные по константе.

Процедура Сформировать()
Перем НаДату;
Перем Инд;

Для Инд=1 По Метаданные.Константа() Цикл
ТабЗнач.Идент = Метаданные.Константа(Инд).Идентификатор;
ТабЗнач.Представление = Метаданные.Константа(Инд).Представление();
ТабЗнач.Комментарий = Метаданные.Константа(Инд).Комментарий;
Если Метаданные.Константа(Инд).Периодический = 1 Тогда
ТабЗнач.ТекЗначение = Константа.ПолучитьАтрибут(ТабЗнач.Идент).Получить(НаДату);
Иначе
ТабЗнач.ТекЗначение = Константа.ПолучитьАтрибут(ТабЗнач.Идент);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Можно также дополнительно прописать процедуры изменения значений констант.

Удачи!


Консультировал: Gl0betrotter
Дата отправки: 08.12.2006, 11:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 66076
Gl0betrotter

# 1

= общий = | 08.12.2006, 11:06

Прошу прощения, практически повторил ответ спеца Зайцева Александра. Добавьте перед циклом строку НаДату=ТекущаяДата(); //или любая нужная Вам дата...

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.27814 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.65 от 20.01.2019
Версия JS: 1.31 | Версия CSS: 3.35