24.09.2018, 07:41 [+3 UTC]
в нашей команде: 2 973 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.50 (13.09.2018)

Общие новости:
13.04.2018, 10:33

Форум:
21.09.2018, 12:18

Последний вопрос:
23.09.2018, 21:57

Последний ответ:
24.09.2018, 06:27

Последняя рассылка:
23.09.2018, 18:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
16.11.2016, 17:52 »
svrvsvrv
Спасибо за принцип решения [вопрос № 190047, ответ № 274264]
21.11.2009, 19:09 »
gorulll
Спасибо за ответ! Так и думал, что с картой придется попрощаться. По моему за 4-5 т.р. есть более производительные карточки. [вопрос № 174406, ответ № 256766]
06.06.2010, 21:11 »
Поттер Г.
Большое спасибо за помощь [вопрос № 178891, ответ № 261895]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66076
Раздел: [неизвестная рассылка]
Автор вопроса: Ирка
Отправлена: 08.12.2006, 10:29
Поступило ответов: 3

Здравствуйте! Подскажите,пожалуйста,можно ли в 1С программно открыть список констант ?

Состояние: Консультация закрыта

Ответ # 130590 от Зайцев Александр

Здравствуйте, Ирка!
Открыть програмно нельзя, но если есть такая необходимость, то можно сделать свою форму, на форму выложить таблицу значений, и заполнить ее крнстантами примерно так:
//ТЗ - таблица значений на форме
Процедура ПриОткрытии()
Для Инд=1 По Метаданные.Константа() Цикл
ТЗ.НоваяСтрока();
ТЗ.Идент=Метаданные.Константа(Инд).Идентификатор;
ТЗ.Комментарий=Метаданные.Константа(Инд).Комментарий;
КонецЦикла;
КонецПроцедуры;
Если не совсем понятно, то пишите в личку - помогу


Консультировал: Зайцев Александр
Дата отправки: 08.12.2006, 10:47

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130594 от BuhCIA

Здравствуйте, Ирка!
Для Инд = 1 По Метаданные.Константа() Цикл
Идент=Метаданные.Константа(Инд).Идентификатор;
Сообщить(Метаданные.Константа(Инд).Идентификатор+"="+Метаданные.Константа(Идент));
КонецЦикла;
Здесь все три варианта обращения: количество констант, константа по номеру, константа по идентификатору. Проверка идентификатора:
Если Метаданные.Константа(Идент).Выбран()=0 Тогда
Сообщить("нет такой константы "+Идент);
КонецЕсли;


Консультировал: BuhCIA
Дата отправки: 08.12.2006, 10:57

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130595 от Gl0betrotter

Здравствуйте, Ирка!

О программном открытии не слышал - предлагаю использовать обработку с таблицей значений, в которую загонять все данные по константе.

Процедура Сформировать()
Перем НаДату;
Перем Инд;

Для Инд=1 По Метаданные.Константа() Цикл
ТабЗнач.Идент = Метаданные.Константа(Инд).Идентификатор;
ТабЗнач.Представление = Метаданные.Константа(Инд).Представление();
ТабЗнач.Комментарий = Метаданные.Константа(Инд).Комментарий;
Если Метаданные.Константа(Инд).Периодический = 1 Тогда
ТабЗнач.ТекЗначение = Константа.ПолучитьАтрибут(ТабЗнач.Идент).Получить(НаДату);
Иначе
ТабЗнач.ТекЗначение = Константа.ПолучитьАтрибут(ТабЗнач.Идент);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Можно также дополнительно прописать процедуры изменения значений констант.

Удачи!


Консультировал: Gl0betrotter
Дата отправки: 08.12.2006, 11:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 66076

Посетитель

ID: 22405

# 1

= общий = | 08.12.2006, 11:06 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

Прошу прощения, практически повторил ответ спеца Зайцева Александра. Добавьте перед циклом строку НаДату=ТекущаяДата(); //или любая нужная Вам дата...

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.14507 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.50 от 13.09.2018