19.02.2019, 21:05 [+3 UTC]
в нашей команде: 3 396 чел. | участники онлайн: 9 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.69 (10.02.2019)
JS-v.1.33 | CSS-v.3.35

Общие новости:
10.02.2019, 21:59

Форум:
16.02.2019, 15:03

Последний вопрос:
19.02.2019, 18:36
Всего: 148779

Последний ответ:
19.02.2019, 15:57
Всего: 257802

Последняя рассылка:
19.02.2019, 20:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
05.12.2017, 04:16 »
Zloe Zlo
Спасибо,Вам огромное Андрей Владимирович!)) [вопрос № 191991, ответ № 275740]
07.05.2012, 16:58 »
STamara
Спасибо большое. Ваш ответ очень мне помог [вопрос № 185980, ответ № 270724]
20.02.2010, 16:14 »
Сергей К.
Понятно, спасибо. [вопрос № 176791, ответ № 259605]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66062
Раздел: [неизвестная рассылка]
Автор вопроса: Andru
Отправлена: 08.12.2006, 08:50
Поступило ответов: 5

Здравствуйте Уважаемые Эксперты!
Есть небольшая проблемма с выгрузской из табличной части реализации Торговли 9.0 в Excell. Вопрос: как можно при этом доработать файл выгрузки чтоб к ниже перечисленным колонкам выгружался КОД выгружаемого товара (Наименование), те обращение к справочнику номенклатура, тк в табличной части кода нет. Вот файл:
Процедура Выгрузить()
Спр = СоздатьОбъект ("Справочник.Номенклатура");
Табл = СоздатьОбъект("Таблица");
ПечТабл = СоздатьОбъект("Таблица");
Док.ВыгрузитьТабличнуюЧасть(Табл,);
Табл.ВыбратьСтроки();
Пока Табл.ПолучитьСтроку() = 1 Цикл
Номенклатура = Табл.Номенклатура;
Количество = Табл.Количество;
Цена = Табл.Цена;
Сумма = Табл.Сумма;
СуммаНдс = Окр(Табл.СуммаНДС, 2, 1);
ПечТабл.ВывестиСекцию("Строка");
КонецЦикла;
ПечТабл.Показать("Выгруженный товар","");
КонецПроцедуры
Заранее Спасибо, Андрей!

Состояние: Консультация закрыта

Ответ # 130569 от Зайцев Александр

Здравствуйте, Andru!
Добавьте после строки Номенклатура = Табл.Номенклатура; следующий код
Спр.НайтиПоНаименованию (Номенклатура,0,1);
Код = Спр.Код;

И измените
Табл = СоздатьОбъект("ТаблицаЗначений");


Консультировал: Зайцев Александр
Дата отправки: 08.12.2006, 09:04

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130571 от Munster

Здравствуйте, Andru!
Можно попробовать делать выборку не таблицы значений, а самого документа.
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
Код=Док.Номенклаткра.Код;
//далее по тексту


Консультировал: Munster
Дата отправки: 08.12.2006, 09:17

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130572 от IUnknown

Здравствуйте, Andru!
если я правильно понял вопрос то вам пожет следующее

Код = Табл.Номенклатура.Код;


Консультировал: IUnknown
Дата отправки: 08.12.2006, 09:17

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130580 от Strawberry

Здравствуйте, Andru!
Процедура Выгрузить()
Спр = СоздатьОбъект ("Справочник.Номенклатура");
Табл = СоздатьОбъект("Таблица");
ПечТабл = СоздатьОбъект("Таблица");
Док.ВыгрузитьТабличнуюЧасть(Табл,);
Табл.ВыбратьСтроки();
Пока Табл.ПолучитьСтроку() = 1 Цикл
Код=Табл.Номенклатура.Код;
Номенклатура = Табл.Номенклатура;
Количество = Табл.Количество;
Цена = Табл.Цена;
Сумма = Табл.Сумма;
СуммаНдс = Окр(Табл.СуммаНДС, 2, 1);
ПечТабл.ВывестиСекцию("Строка");
КонецЦикла;
ПечТабл.Показать("Выгруженный товар","");
КонецПроцедуры


Консультировал: Strawberry
Дата отправки: 08.12.2006, 09:59

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131058 от Ovr1970

Здравствуйте, Andru!
Нужно в талице, которая выводится, добавить еще одну колонку, в которой поставить заголовок КОД и в этой колонке в секции "Строка" выражение "Номенклатура.код"


Консультировал: Ovr1970
Дата отправки: 11.12.2006, 13:27

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 66062
неизвестный

# 1

= общий = | 08.12.2006, 09:47

Спасибо!

неизвестный

# 2

= общий = | 08.12.2006, 09:53

Супер! Все работает! Спасибо ЛЮДИ ДОБРЫЕ!!! очень помогли!

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.15548 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.69 от 10.02.2019
Версия JS: 1.33 | Версия CSS: 3.35