23.06.2018, 13:29 [+3 UTC]
в нашей команде: 2 854 чел. | участники онлайн: 2 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.47 (16.04.2018)

Общие новости:
13.04.2018, 10:33

Форум:
18.06.2018, 08:55

Последний вопрос:
23.06.2018, 07:43

Последний ответ:
23.06.2018, 07:26

Последняя рассылка:
23.06.2018, 00:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
01.12.2010, 00:17 »
Посетитель - 348444
Всё очень понятно и наглядно, большое спасибо! [вопрос № 181030, ответ № 264445]
09.10.2010, 00:40 »
Сучкова Татьяна Михайловна
Действительно, там оказалось одно неизвестное устройство, после удаления его флэшка определилась. Спасибо! [вопрос № 180239, ответ № 263394]
31.03.2011, 13:45 »
Данилов Евгений
Спасибо за информацию, но суть вопроса не в нахождении бесплатного хостинга, а именно в посторойке своего веб сервера. я щас пользуюсь услугами хостера, в районе 140р в месяц - совсем не напряжно. Но как я объяснял, поднадоело и хотелось бы разобраться с созданием своего сервера. [вопрос № 182680, ответ № 266490]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 66062
Раздел: [неизвестная рассылка]
Автор вопроса: Andru
Отправлена: 08.12.2006, 08:50
Поступило ответов: 5

Здравствуйте Уважаемые Эксперты!
Есть небольшая проблемма с выгрузской из табличной части реализации Торговли 9.0 в Excell. Вопрос: как можно при этом доработать файл выгрузки чтоб к ниже перечисленным колонкам выгружался КОД выгружаемого товара (Наименование), те обращение к справочнику номенклатура, тк в табличной части кода нет. Вот файл:
Процедура Выгрузить()
Спр = СоздатьОбъект ("Справочник.Номенклатура");
Табл = СоздатьОбъект("Таблица");
ПечТабл = СоздатьОбъект("Таблица");
Док.ВыгрузитьТабличнуюЧасть(Табл,);
Табл.ВыбратьСтроки();
Пока Табл.ПолучитьСтроку() = 1 Цикл
Номенклатура = Табл.Номенклатура;
Количество = Табл.Количество;
Цена = Табл.Цена;
Сумма = Табл.Сумма;
СуммаНдс = Окр(Табл.СуммаНДС, 2, 1);
ПечТабл.ВывестиСекцию("Строка");
КонецЦикла;
ПечТабл.Показать("Выгруженный товар","");
КонецПроцедуры
Заранее Спасибо, Андрей!

Состояние: Консультация закрыта

Ответ # 130569 от Зайцев Александр

Здравствуйте, Andru!
Добавьте после строки Номенклатура = Табл.Номенклатура; следующий код
Спр.НайтиПоНаименованию (Номенклатура,0,1);
Код = Спр.Код;

И измените
Табл = СоздатьОбъект("ТаблицаЗначений");


Консультировал: Зайцев Александр
Дата отправки: 08.12.2006, 09:04

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130571 от Munster

Здравствуйте, Andru!
Можно попробовать делать выборку не таблицы значений, а самого документа.
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
Код=Док.Номенклаткра.Код;
//далее по тексту


Консультировал: Munster
Дата отправки: 08.12.2006, 09:17

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130572 от IUnknown

Здравствуйте, Andru!
если я правильно понял вопрос то вам пожет следующее

Код = Табл.Номенклатура.Код;


Консультировал: IUnknown
Дата отправки: 08.12.2006, 09:17

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130580 от Strawberry

Здравствуйте, Andru!
Процедура Выгрузить()
Спр = СоздатьОбъект ("Справочник.Номенклатура");
Табл = СоздатьОбъект("Таблица");
ПечТабл = СоздатьОбъект("Таблица");
Док.ВыгрузитьТабличнуюЧасть(Табл,);
Табл.ВыбратьСтроки();
Пока Табл.ПолучитьСтроку() = 1 Цикл
Код=Табл.Номенклатура.Код;
Номенклатура = Табл.Номенклатура;
Количество = Табл.Количество;
Цена = Табл.Цена;
Сумма = Табл.Сумма;
СуммаНдс = Окр(Табл.СуммаНДС, 2, 1);
ПечТабл.ВывестиСекцию("Строка");
КонецЦикла;
ПечТабл.Показать("Выгруженный товар","");
КонецПроцедуры


Консультировал: Strawberry
Дата отправки: 08.12.2006, 09:59

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 131058 от Ovr1970

Здравствуйте, Andru!
Нужно в талице, которая выводится, добавить еще одну колонку, в которой поставить заголовок КОД и в этой колонке в секции "Строка" выражение "Номенклатура.код"


Консультировал: Ovr1970
Дата отправки: 11.12.2006, 13:27

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 66062

Посетитель

ID: 27905

# 1

= общий = | 08.12.2006, 09:47 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

Спасибо!


Посетитель

ID: 27905

# 2

= общий = | 08.12.2006, 09:53 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

Супер! Все работает! Спасибо ЛЮДИ ДОБРЫЕ!!! очень помогли!

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.14798 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.47 от 16.04.2018