19.01.2019, 02:14 [+3 UTC]
в нашей команде: 3 337 чел. | участники онлайн: 1 (рекорд: 20)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.64 (07.01.2019)
JS-v.1.31 | CSS-v.3.35

Общие новости:
01.01.2019, 13:54

Форум:
14.01.2019, 10:08

Последний вопрос:
18.01.2019, 19:47
Всего: 148522

Последний ответ:
19.01.2019, 00:57
Всего: 257600

Последняя рассылка:
18.01.2019, 15:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
14.03.2010, 08:09 »
Березин Вадим Юрьевич
Всё понятно, лаконичнои главное приведена юридическая хитрость. Пять! [вопрос № 177218, ответ № 260095]
17.09.2009, 20:49 »
Dimon4ik
Спасибо. Теперь все работает! [вопрос № 172280, ответ № 254317]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 65844
Раздел: [неизвестная рассылка]
Автор вопроса: Darina
Отправлена: 06.12.2006, 20:31
Поступило ответов: 3

Здравствуйте! Снова с Вам за помощью. После выполнения процедуры Заполнить() заполнятся ТЗ, которая состоит из, например, 3-х колонок, строки заполняются вразнобой. Т.е., например,
Аренда Налоги Зарплата
1200,00
1000,00
1300,00 300,00
а надо бы построчно.
Надеюсь вопрос понятен. Помогите пожалуйста, а то по-всякому пробовала, и в итоге посылаю как писала изначально.
И второй вопросик: можно ли из таблицы значений, нажав на Сумму, перейти для просмотра в документ из которого эта сумма взята?

Приложение:

Состояние: Консультация закрыта

Ответ # 130395 от Vizli

Здравствуйте, Darina!

1. можно добавить в ТЗ колонку "Документ" и использовать метод Свернуть("Документ","Аренда, Зарплата, Налоги") тогда для каждого документа будет одна строка в ТЗ.

2. Т.к. в ТЗ есть ссылкана документ, то для перехода на него делаем кнопку и пишем, в процедуре нажатия анализируем текущюу строку ТЗ и выбираем из колонки Документ ссылку и открываем методом ОткрытьФорму существующего документа

Приложение:


Консультировал: Vizli
Дата отправки: 07.12.2006, 06:03

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130399 от Гребиников Павел Генадьевич

Здравствуйте, Darina!
А как вы хотите построчно???
Ведь у вас может идти подряд несколько документов с одинаковыми значениями, т.е. например Аренда может идти несколько раз. Если я правильно понял ВАм ндо чтоб было примерно так:
Аренда/ Налоги/ Зарплата
1000/2000/3000
2000/4000/2000
и.т.д.
тут можете попробовать при каждом новом значении искать последнюю заполненную нужную графу и вставлять туда ваше значение, что то типа как в приложении:
в коде могут быть ошибки,и надо добавить обработчик вставки новой строки, но принцып, я думаю, понятен
А насчет второго вопроса, то пользуйтесь предопределенной процедурой ОбработкаЯчейкиТаблицы().

Приложение:


Консультировал: Гребиников Павел Генадьевич
Дата отправки: 07.12.2006, 07:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 130407 от Полозов Олег aka Asher

Здравствуйте, Darina!
Ну думаю, что надо как то вот так...
Процедура Заполнить()
ТЗ1.УдалитьСтроки();
Док = СоздатьОбЪект("Документ.РасходныйОрдер");
// Выбирам документы за период.
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
//Проходим по каждому документу
Пока Док.ПолучитьДокумент() = 1 Цикл
Если Док.Выбран() = 1 Тогда
Док.ВыбратьСтроки();
ТЗ1.НоваяСтрока();
СуммаАренда = 0;
СуммаЗарплата = 0;
СуммаНалоги = 0;
// А вот сдесь выбираем строки
Пока Док.ПолучитьСтроку() = 1 Цикл
// Распихаем суммы по видам
Если Док.Субконто1 = Перечисление.СтатьиИздержек.Аренда Тогда
СуммаАренда = Док.Сумма;
ИначеЕсли Док.Субконто1 = Перечисление.СтатьиИздержек.ОплатаТруда Тогда
СуммаЗарплата = Док.Сумма;
ИначеЕсли Док.Субконто1 = Перечисление.СтатьиИздержек.Отчисления Тогда
СуммаНалоги = Док.Сумма;
КонецЕсли;
КонецЦикла;
// И соберем в строку таблицы
ТЗ1.Аренда = СуммаАренда;
ТЗ1.Зарплата = СуммаЗарплата;
ТЗ1.Налоги = СуммаЗарплата;
КонецЕсли;
КонецЦикла;
Если ТЗ1.КоличествоСтрок()=0 Тогда
Предупреждение("За данный период нет расходов!",10);
КонецЕсли;
КонецПроцедуры


Консультировал: Полозов Олег aka Asher
Дата отправки: 07.12.2006, 08:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13739 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.64 от 07.01.2019
Версия JS: 1.31 | Версия CSS: 3.35