13.12.2017, 19:43 [+3 UTC]
в нашей команде: 2 375 чел. | участники онлайн: 13 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
13.12.2017, 19:03

Последний вопрос:
13.12.2017, 17:01

Последний ответ:
13.12.2017, 18:39

Последняя рассылка:
13.12.2017, 18:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
04.08.2017, 16:02 »
Валерий
Спасибо, все разобрал! Единственное, в уравнении (1) коэффициент при y должен быть не -1, а 1, но эта опечатка ни на что не влияет, так как дальше мы имеем квадрат. [вопрос № 191255, ответ № 275181]
21.06.2011, 05:33 »
Данилов Артем Владимирович
Спасибо за развернутый ответ [вопрос № 183650, ответ № 267786]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 65083
Раздел: [неизвестная рассылка]
Автор вопроса: Игорь К.
Отправлена: 01.12.2006, 12:29
Поступило ответов: 1

Доброго времени суток!
Вопрос:
Нужно выяснить из чего (каких документов и на какие суммы) состоит, допустим, кредиторская задолженность по счету 60.1
Делаю так:
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,,1);
Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,,1);
Ит.ВыполнитьЗапрос(ОтчДата,ОтчДата,СчетПоКоду("60.1"));
Если Ит.СКК()>0 Тогда
ИтДоп.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Ит.Субконто(1),1);
ИтДоп.ИспользоватьСубконто(ВидыСубконто.Договоры,Ит.Субконто(2),1);
ИтДоп.ВыполнитьЗапрос(ДатаНачалаВеденияУчета1С,ОтчДата,СчетПоКоду("60.1"),,,3,3);
ИтДоп.ВыбратьПериоды(1,2);
Пока ИтДоп.ПолучитьПериод()=1 Тогда

Тут загоняю все в таблицу значений, сортирую в обратном (по Дате и Времени) порядке и могу выяснить какие же документы составляют это сальдо, но проблема в том что это долго. Безумно долго. База уже 5 лет и документов которые надо перебрать очень много.
1. Есть ли типа переключатель "обратный порядок" для Бухгалтерских Итогов ?
2. Как это сделать быстрее другими способами?

Состояние: Консультация закрыта

Ответ # 129467 от Шахрайчук Владимир Анатольевич

Здравствуйте, Игорь К.!
Модернизация может быть в том, что в ИтДоп.ВыполнитьЗапрос вы выполняете запрос по одному контрагенту, а нужно выполнить этот запрос 1 раз, но по всем контрагентам.

Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,,1);
Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,,1);
Ит.ВыполнитьЗапрос(ОтчДата,ОтчДата,СчетПоКоду("60.1"));
ИтДоп.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
ИтДоп.ИспользоватьСубконто(ВидыСубконто.Договоры);
ИтДоп.ВыполнитьЗапрос(ДатаНачалаВеденияУчета1С,ОтчДата,СчетПоКоду("60.1"),,,3,3);
Если Ит.СКК()>0 Тогда
Если ИтДоп.ПолучитьСубконто(1,,Ит.Субконто(1))=1 Тогда
Если ИтДоп.ПолучитьСубконто(2,,Ит.Субконто(2))=1 Тогда
ИтДоп.ВыбратьПериоды(1,2);
Пока ИтДоп.ПолучитьПериод()=1 Тогда

Таким образом, страшно долгий запрос выполнится 1 раз.
ПолучитьСубконто работает очень быстро.


Консультировал: Шахрайчук Владимир Анатольевич
Дата отправки: 01.12.2006, 13:37

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 65083

Посетитель

ID: 20632

# 1

= общий = | 01.12.2006, 14:27 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

To : Шахрайчук Владимир Анатольевич Как раз наоборот. В тексте пропущены 2 строчки с циклами по контрагентам и договорам от первого запроса, думаю это и так понятно. таким образом подзапросы ИтДоп крутятся только у тех контрагентов с договорами у которых есть СКК, в сумме по времени получается быстрее. Ваш ответ прыжок в сторону. Ниже более полный кусок: Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1); Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,, 1); Ит.ИспользоватьСубконто(ВидыСубконто.ОтделыМГ,, 1); Если Ит.ВыполнитьЗапрос(КонДата, КонДата, СчетПоКоду("60.1")) = 0 Тогда Возврат; КонецЕсли; Состояние("Выбираем данные"); Ит.ВыбратьСубконто(1); Пока Ит.ПолучитьСубконто(1) = 1 Цикл Ит.ВыбратьСубконто(2); Пока Ит.ПолучитьСубконто(2) = 1 Цикл Ит.ВыбратьСубконто(3); Пока Ит.ПолучитьСубконто(3) = 1 Цикл Если (Ит.СКК()>0) Тогда Ит0.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Ит.Субконто(1), 1); Ит0.ИспользоватьСубконто(ВидыСубконто.Договоры,Ит.Субконто(2), 1); Ит0.ИспользоватьСубконто(ВидыСубконто.ОтделыМГ,Ит.Субконто(3), 1); Ит0.ВыполнитьЗапрос("01.01.2002",КонДата,СчетПоКоду("60.1"),,,3,2,"С"); Ит0.ВыбратьПериоды(); Пока Ит0.ПолучитьПериод() = 1 Цикл . . . КонецЦикла; КонецЕсли; КонецЦикла; КонецЦикла; КонецЦикла;

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.93747 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн