18.10.2017, 10:25 [+3 UTC]
в нашей команде: 2 177 чел. | участники онлайн: 5 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
18.10.2017, 03:28

Последний вопрос:
17.10.2017, 19:30

Последний ответ:
18.10.2017, 06:25

Последняя рассылка:
18.10.2017, 00:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
22.01.2012, 16:18 »
Посетитель - 391721
Большое спасибо!!! [вопрос № 185238, ответ № 269664]
14.08.2011, 07:53 »
korsar
Спасибо за подробный ответ [вопрос № 183865, ответ № 268031]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 64838
Раздел: [неизвестная рассылка]
Автор вопроса: Darina
Отправлена: 29.11.2006, 22:52
Поступило ответов: 2

Здравствуйте! В отчете (см.приложение) сообщается, что у такого-то сотрудника день рождения. А как можно по-другому это описать? Какие у вас варианты есть? И можно ли как-то описать дату без года. И отсюда я хочу, чтобы каждый день можно было просмотреть, что через n-дней у сотрудника день рождения. Подскажите кто может пожалуйста, очень интересно.

Приложение:

Состояние: Консультация закрыта

Ответ # 129210 от Полозов Олег aka Asher

Здравствуйте, Darina!
Вот модуль обработки, в принципе можно переделать на ваше усмотрение чтобы выполнялось при запуске системы
№1 Это просто по дням рождения:

//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Наименование = Справочник.Сотрудники.Наименование;
|ДатаРождения = Справочник.Сотрудники.ФизЛицо.ДатаРождения;
|Группировка Наименование;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Пока Запрос.Группировка(1) = 1 Цикл
Год = ДатаГод(Запрос.ДатаРождения);
Месяц = ДатаМесяц(Запрос.ДатаРождения);
День = ДатаЧисло(Запрос.ДатаРождения);

ТекГод = ДатаГод(РабочаяДата());
ТекМесяц = ДатаМесяц(РабочаяДата());
ТекДень = ДатаЧисло(РабочаяДата());
Если (День = ТекДень) и (Месяц = ТекМесяц) Тогда
Возраст = ТекГод - Год;
// Заполнение полей Наименование
Таб.ВывестиСекцию("Наименование");
КонецЕсли
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры

№2 вариант с предупреждением за три дня

//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Наименование = Справочник.Сотрудники.Наименование;
|ДатаРождения = Справочник.Сотрудники.ФизЛицо.ДатаРождения;
|Группировка Наименование;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Пока Запрос.Группировка(1) = 1 Цикл
Год = ДатаГод(Запрос.ДатаРождения);
Месяц = ДатаМесяц(Запрос.ДатаРождения);
День = ДатаЧисло(Запрос.ДатаРождения);

ТекГод = ДатаГод(РабочаяДата());
ТекМесяц = ДатаМесяц(РабочаяДата());
ТекДень = ДатаЧисло(РабочаяДата());
Если ((День < ТекДень) и (День > ТекДень - 4)и (Месяц = ТекМесяц) Тогда
Если ТекДень - День = 0 Тогда
Когда = "Сегодня!!!";
Иначе
КолВоДней = ТекДень - День;
Когда = "Через" + КолВоДней + "дн.";
КонецЕсли;
Возраст = ТекГод - Год;
// Заполнение полей Наименование
Таб.ВывестиСекцию("Наименование");
КонецЕсли
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Консультировал: Полозов Олег aka Asher
Дата отправки: 30.11.2006, 04:26

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 129281 от Elric

Здравствуйте, Darina!

В варианте от Полозов Олег aka Asher строчка
Если ((День < ТекДень) и (День > ТекДень - 4)и (Месяц = ТекМесяц) Тогда
не сработает если день рождения в первых числах месяца
Лучше при проверке приводить даты к одному году и просто вычитать одну из другой -- получим количество дней.

ДатДР=Дата(Лев(Сотр.ДатаРождения,6)+Сред(ТекущаяДата(),7)); // Вычислили дату дня рождения в ТЕКУЩЕМ году
КвоДнейДоДР=ТекущаяДата()-ДатДР;


Консультировал: Elric
Дата отправки: 30.11.2006, 12:20

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13697 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн