16.08.2017, 18:05 [+3 UTC]
в нашей команде: 2 090 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
09.08.2017, 19:27

Последний вопрос:
16.08.2017, 15:26

Последний ответ:
16.08.2017, 17:10

Последняя рассылка:
14.08.2017, 21:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
03.03.2010, 18:43 »
Falcon
Спасибо за подробный ответ! Буду искать. Хотя уже начинаю задумываться о замене материнской платы. [вопрос № 176970, ответ № 259795]
06.04.2017, 20:59 »
Анатолий
лишняя программа... ворд не очень удобно использовать... использовал дежавю при открытии,в которой нет проблем для выделения изображения и текста.... и растянуть размер тоже... [вопрос № 190788, ответ № 274875]
13.06.2011, 12:19 »
Посетитель - 358526
Спасибо за решение задачи! [вопрос № 183605, ответ № 267709]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 64542
Раздел: [неизвестная рассылка]
Автор вопроса: Гребиников Павел Генадьевич
Отправлена: 28.11.2006, 08:04
Поступило ответов: 4

Добрый день, уважемые эксперты.
Подскажите, как узнать, есть ли у числа дробная часть или нет
например 2-нет дробнойчасти, 2,5-есть

Состояние: Консультация закрыта

Ответ # 128872 от Зайцев Александр

Здравствуйте, Гребиников Павел Генадьевич!
Программно, см. приложение

Приложение:


Консультировал: Зайцев Александр
Дата отправки: 28.11.2006, 08:15

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128876 от nimoid

Здравствуйте, Гребиников Павел Генадьевич!

Еще можно так:

Если Найти(Строка(ТвоеЧисло), ",") = 1 Тогда Сообщить("дробная часть есть"); КонецЕсли;


Консультировал: nimoid
Дата отправки: 28.11.2006, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Здравствуйте, Гребиников Павел Генадьевич!
Если Цел(Число1) = Число1 Тогда
//Число целое
иначе
//дробное
КонеЕсли;


Консультировал: ATan
Дата отправки: 28.11.2006, 10:05

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128973 от Лазурко Владимир

Здравствуйте, Гребиников Павел Генадьевич!
Процедура Сформировать()
Если ИсследуемоеЧисло-Цел(ИсследуемоеЧисло) = 0 Тогда
Сообщить("Число целое");
Иначе
Сообщить("ЧИсло дробное");
КонецЕсли;
КонецПроцедуры


Консультировал: Лазурко Владимир
Дата отправки: 28.11.2006, 19:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13226 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн