24.10.2017, 12:38 [+3 UTC]
в нашей команде: 2 194 чел. | участники онлайн: 8 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
24.10.2017, 12:34

Последний вопрос:
24.10.2017, 11:14

Последний ответ:
23.10.2017, 15:50

Последняя рассылка:
23.10.2017, 17:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
28.04.2010, 16:19 »
Anjali
Действительно оказались эти вирусы. Всё получилось. [вопрос № 178009, ответ № 260991]
04.02.2010, 22:34 »
Кадынцев Валерий Васильевич
Спасибо! Рассказано подробно. [вопрос № 176490, ответ № 259217]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 64542
Раздел: [неизвестная рассылка]
Автор вопроса: Гребиников Павел Генадьевич
Отправлена: 28.11.2006, 08:04
Поступило ответов: 4

Добрый день, уважемые эксперты.
Подскажите, как узнать, есть ли у числа дробная часть или нет
например 2-нет дробнойчасти, 2,5-есть

Состояние: Консультация закрыта

Ответ # 128872 от Зайцев Александр

Здравствуйте, Гребиников Павел Генадьевич!
Программно, см. приложение

Приложение:


Консультировал: Зайцев Александр
Дата отправки: 28.11.2006, 08:15

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128876 от nimoid

Здравствуйте, Гребиников Павел Генадьевич!

Еще можно так:

Если Найти(Строка(ТвоеЧисло), ",") = 1 Тогда Сообщить("дробная часть есть"); КонецЕсли;


Консультировал: nimoid
Дата отправки: 28.11.2006, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Здравствуйте, Гребиников Павел Генадьевич!
Если Цел(Число1) = Число1 Тогда
//Число целое
иначе
//дробное
КонеЕсли;


Консультировал: ATan
Дата отправки: 28.11.2006, 10:05

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128973 от Лазурко Владимир

Здравствуйте, Гребиников Павел Генадьевич!
Процедура Сформировать()
Если ИсследуемоеЧисло-Цел(ИсследуемоеЧисло) = 0 Тогда
Сообщить("Число целое");
Иначе
Сообщить("ЧИсло дробное");
КонецЕсли;
КонецПроцедуры


Консультировал: Лазурко Владимир
Дата отправки: 28.11.2006, 19:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.14161 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн