16.01.2018, 16:39 [+3 UTC]
в нашей команде: 2 475 чел. | участники онлайн: 9 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.42 (30.12.2017)

Общие новости:
02.01.2018, 09:46

Форум:
12.01.2018, 10:25

Последний вопрос:
16.01.2018, 16:04

Последний ответ:
16.01.2018, 13:00

Последняя рассылка:
16.01.2018, 13:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
18.09.2015, 16:28 »
Василий Игнатюк
Парни, реально молодцы! Отличный ресурс. Как я понял тут снова все стало бесплатным? Мудрое решение. Наверное подпишусь экспертом.

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 64542
Раздел: [неизвестная рассылка]
Автор вопроса: Гребиников Павел Генадьевич
Отправлена: 28.11.2006, 08:04
Поступило ответов: 4

Добрый день, уважемые эксперты.
Подскажите, как узнать, есть ли у числа дробная часть или нет
например 2-нет дробнойчасти, 2,5-есть

Состояние: Консультация закрыта

Ответ # 128872 от Зайцев Александр

Здравствуйте, Гребиников Павел Генадьевич!
Программно, см. приложение

Приложение:


Консультировал: Зайцев Александр
Дата отправки: 28.11.2006, 08:15

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128876 от nimoid

Здравствуйте, Гребиников Павел Генадьевич!

Еще можно так:

Если Найти(Строка(ТвоеЧисло), ",") = 1 Тогда Сообщить("дробная часть есть"); КонецЕсли;


Консультировал: nimoid
Дата отправки: 28.11.2006, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Здравствуйте, Гребиников Павел Генадьевич!
Если Цел(Число1) = Число1 Тогда
//Число целое
иначе
//дробное
КонеЕсли;


Консультировал: ATan
Дата отправки: 28.11.2006, 10:05

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128973 от Лазурко Владимир

Здравствуйте, Гребиников Павел Генадьевич!
Процедура Сформировать()
Если ИсследуемоеЧисло-Цел(ИсследуемоеЧисло) = 0 Тогда
Сообщить("Число целое");
Иначе
Сообщить("ЧИсло дробное");
КонецЕсли;
КонецПроцедуры


Консультировал: Лазурко Владимир
Дата отправки: 28.11.2006, 19:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.17810 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.42 от 30.12.2017