21.06.2018, 05:50 [+3 UTC]
в нашей команде: 2 852 чел. | участники онлайн: 1 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.47 (16.04.2018)

Общие новости:
13.04.2018, 10:33

Форум:
18.06.2018, 08:55

Последний вопрос:
20.06.2018, 15:21

Последний ответ:
20.06.2018, 21:12

Последняя рассылка:
21.06.2018, 03:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
27.05.2010, 22:36 »
skatet
Респект! Все работает как надо smile [вопрос № 178665, ответ № 261708]
01.08.2010, 20:11 »
Dimon4ik
Спасибо. Драйвер удалось откатить на старый. Тот действительно был не рабочий. DirectX установил с диска с игрой. Но там видимо не та версия. Сейчас качаю DirectX 9.0с - 104 МБ. Установлю и посмотрим. Спасибо за ответ. smile [вопрос № 179640, ответ № 262710]
19.11.2010, 13:05 »
Ольга Андреева
Спасибо. Посмотрела по ссылке, действительно была такая проблема. Базы антивируса у меня обновляются автоматически, но все равно срабатывают на этот файл. Буду пробовать восстанавливать файл. [вопрос № 180852, ответ № 264197]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 64542
Раздел: [неизвестная рассылка]
Автор вопроса: Гребиников Павел Генадьевич
Отправлена: 28.11.2006, 08:04
Поступило ответов: 4

Добрый день, уважемые эксперты.
Подскажите, как узнать, есть ли у числа дробная часть или нет
например 2-нет дробнойчасти, 2,5-есть

Состояние: Консультация закрыта

Ответ # 128872 от Зайцев Александр

Здравствуйте, Гребиников Павел Генадьевич!
Программно, см. приложение

Приложение:


Консультировал: Зайцев Александр
Дата отправки: 28.11.2006, 08:15

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128876 от nimoid

Здравствуйте, Гребиников Павел Генадьевич!

Еще можно так:

Если Найти(Строка(ТвоеЧисло), ",") = 1 Тогда Сообщить("дробная часть есть"); КонецЕсли;


Консультировал: nimoid
Дата отправки: 28.11.2006, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Здравствуйте, Гребиников Павел Генадьевич!
Если Цел(Число1) = Число1 Тогда
//Число целое
иначе
//дробное
КонеЕсли;


Консультировал: ATan
Дата отправки: 28.11.2006, 10:05

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128973 от Лазурко Владимир

Здравствуйте, Гребиников Павел Генадьевич!
Процедура Сформировать()
Если ИсследуемоеЧисло-Цел(ИсследуемоеЧисло) = 0 Тогда
Сообщить("Число целое");
Иначе
Сообщить("ЧИсло дробное");
КонецЕсли;
КонецПроцедуры


Консультировал: Лазурко Владимир
Дата отправки: 28.11.2006, 19:01

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13695 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.47 от 16.04.2018