14.12.2017, 07:06 [+3 UTC]
в нашей команде: 2 375 чел. | участники онлайн: 5 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
13.12.2017, 21:07

Последний вопрос:
13.12.2017, 21:22

Последний ответ:
13.12.2017, 22:25

Последняя рассылка:
14.12.2017, 02:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
08.04.2017, 11:21 »
svrvsvrv
Большое спасибо за подробный ответ [вопрос № 190844, ответ № 274887]
03.04.2010, 21:19 »
paramediс
Спасибо за ответ =)Немного дополнения в мини-форуме. [вопрос № 177633, ответ № 260563]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 63813
Раздел: [неизвестная рассылка]
Автор вопроса: Koldun
Отправлена: 23.11.2006, 08:33
Поступило ответов: 6

Всем здравствуйте...
Вопрос такой.Есть нестандартная конфигурация для фирмы.Есть обработка "Пакетная печать документов"(счета,акта,счета-фактуры).
Бухом приходится каждый раз выбирать документ и печатать его(счет-печатать,акт-печатать) вообщем надоело им говорят сделай чтоб сразу три.Можно соединить выходные в одну?

Состояние: Консультация закрыта

Ответ # 127964 от Vizli

Здравствуйте, Koldun!

конечно можно. правда из вопроса не ясно что это за пакетная обработка - самописная или нет, поэтому конкретно строками кода ответить нельзя. если есть подробности пиши на мыло.


Консультировал: Vizli
Дата отправки: 23.11.2006, 08:47

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 127969 от Шальков Павел Владимирович

Здравствуйте, Koldun!
Если конфигурация в 7.7, то объединить в одну таблицу не получится. - в 7.7 не поддерживается различная ширина колонок в таблице. Т.е. все равно придется раскидать формы по разным таблицам. А в 8.0 можно без проблем.


Консультировал: Шальков Павел Владимирович
Дата отправки: 23.11.2006, 09:03

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 127977 от Игорь К.

Здравствуйте, Koldun!

Можно!

Надо немного изменить обработку.

Диалог типа:
сначала по вертикали 3 чек-бокса для выбора какие из 3 документов печатать
рядом по вертикали количество экземляров. И одну кнопку печатать.
В обработчике этой кнопки
Если ЧекБоксСчет.Выбран()=1 Тогда
. . .
i=0
Пока i<КолВоЭкземпляровСчета Цикл
вызов процедуры печати счета
i=i+1;
КонецЦикла;
. . .
КонецЕсли;
Если ЧекБоксАкт.Выбран()=1 Тогда
. . .
i=0
Пока i<КолВоЭкземпляровАкта Цикл
вызов процедуры печати акта
i=i+1;
КонецЦикла;
. . .
КонецЕсли;
Если ЧекБоксСчетФактура.Выбран()=1 Тогда
. . .
i=0
Пока i<КолВоЭкземпляровСчетФактуры Цикл
вызов процедуры печати счет-фактуры
i=i+1;
КонецЦикла;
. . .
КонецЕсли;
Это только идея - реализация Вам!
Удачи!


Консультировал: Игорь К.
Дата отправки: 23.11.2006, 09:41

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 127997 от Зайцев Александр

Здравствуйте, Koldun!
Это можно реализовать при выводе сразу на принтер, а не на экран, в обработку включаете три формы, в цикле обрабатываете документы
пока <Получить документ из списка> Цикл
...
табАкт.Напечатать(0);
табСчет.Напечатать(0);
табСФ.Напечатать(0);
...
конеццикла
А при выводе на экран в одну форму это действительно очень сложно, но решаемо с помощью объединения ячеек и т.д., и еще тут есть проблема, с настройками ориентации листа,но в принципе тоже решаемая, если есть желание, могу скинуть одно решение с накладными и с/ф


Консультировал: Зайцев Александр
Дата отправки: 23.11.2006, 11:51

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128057 от Arkadiy Karanskiy

Здравствуйте, Koldun!
Интересный вопрос. Если Вы спрашиваете можно ли это сделать в 1С, то ответ очевиден, что ДА. Но вот как надо непосредственно смотреть на конфигурацию.


Консультировал: Arkadiy Karanskiy
Дата отправки: 23.11.2006, 15:44

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 128136 от Elric

Здравствуйте, Koldun!

А еще как вариант можно сформировать три таблицы (печатные формы) сразу, останется только на печать послать каждую из них smile Это если надо предварительно видеть их на экране. А если видеть не обязательно, то логичнее сразу их на принтер посылать, как сказал Зайцев Александр.


Консультировал: Elric
Дата отправки: 24.11.2006, 00:36

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 63813

Посетитель

ID: 8

# 1

= общий = | 24.11.2006, 02:31 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

Vizli, Arkadiy Karanskiy: если не знаете как - не отвечайте. Если нужны уточнения - вопросы задавать в минифоруме надо

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13642 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн