29.03.2020, 20:58 [+3 UTC]
в нашей команде: 4 310 чел. | участники онлайн: 4 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.83 (12.03.2020)
JS-v.1.35 | CSS-v.3.37

Общие новости:
28.03.2020, 20:29

Форум:
28.03.2020, 21:05

Последний вопрос:
29.03.2020, 17:14
Всего: 151869

Последний ответ:
29.03.2020, 14:22
Всего: 259902

Последняя рассылка:
29.03.2020, 20:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
17.11.2016, 09:22 »
svrvsvrv
Большое спасибо за хорошее и подробное объяснение. [вопрос № 190039, ответ № 274272]
16.10.2009, 14:45 »
PsySex
Спасибо!!! Теперь все понятно. [вопрос № 173271, ответ № 255415]
21.03.2010, 18:23 »
Aleks Brest
Оценка ответа: 5 Комментарий к оценке: Совершенно верно smile [вопрос № 177387, ответ № 260285]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 145410
Раздел: [неизвестная рассылка]
Автор вопроса: Black Monk
Отправлена: 29.09.2008, 13:48
Поступило ответов: 1

Похоже я где-то неуловимо торможу... smile

Задача получение бухгалтерских итогов через ОЛЕ
Платформа 7.7 Конфигурация Бу для Украины от АББИ 7.70.251 сильно переделанная..


Почему: этот код нормально отрабатывает :

© Цитата:
Процедура Сформировать()
перем БиоЛе ;
Если ГлОлеПодключитьБазу(Агентство.ПутьКБухБазе,Агентство.ПользовательВБухБазе,Агентство.ПарольВБухБазе,Агентство.КодФирмы)=0 Тогда
Возврат;
КонецЕсли;
ГлОлеБаза.EvalExpr("глБИ.ИспользоватьПланСчетов(ОсновнойПланСчетов())");
ГлОлеБаза.ExecuteBatch("глБИ.ИспользоватьСубконто(ВидыСубконто.ТМЦ)");
Если ГлОлеФирма <> 0 Тогда
ГлОлеБаза.глБи.ИспользоватьРазделительУчета(ГлОлеФирма);
КонецЕсли;
ГлОлеБаза.глБи.ВыполнитьЗапрос(НачМесяца(ДатаН),НачМесяца(ДатаН),"281",,,1,,1);
БиОле=ГлОлеБаза.глБи;
БиОле.ВыбратьСубконто(1);
Пока БиОле.ПолучитьСубконто(1)=1 Цикл
сообщить( БиОле.Субконто(1).Наименование);
КонецЦикла;
ГлОлеБаза=0;
КонецПроцедуры

А этот НЕТ :
© Цитата:

Процедура Сформировать()
перем БиоЛе ;
Если ГлОлеПодключитьБазу(Агентство.ПутьКБухБазе,Агентство.ПользовательВБухБазе,Агентство.ПарольВБухБазе,Агентство.КодФирмы)=0 Тогда
Возврат;
КонецЕсли;
ГлОлеБаза.EvalExpr("глБИ.ИспользоватьПланСчетов(ОсновнойПланСчетов())");
ГлОлеБаза.ExecuteBatch("глБИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники)");
Если ГлОлеФирма <> 0 Тогда
ГлОлеБаза.глБи.ИспользоватьРазделительУчета(ГлОлеФирма);
КонецЕсли;
ГлОлеБаза.глБи.ВыполнитьЗапрос(НачМесяца(ДатаН),НачМесяца(ДатаН),"661",,,1,,1);
БиОле=ГлОлеБаза.глБи;
БиОле.ВыбратьСубконто(1);
Пока БиОле.ПолучитьСубконто(1)=1 Цикл
сообщить( БиОле.Субконто(1).Наименование);
КонецЦикла;
ГлОлеБаза=0;
КонецПроцедуры

Они отличаются только счетом и видом субконто .....
При запуске под отладчиком второго фрагмента пишет :
© Цитата:
БиОле.ВыбратьСубконто(1) Данная операция допустима только в режиме запроса по аналитике !


Аналогичный запрос с такими же параметрами в конфигурации нормально отрабатывается...

А через ОЛЕ не хочет :(
Счет и субконто в плане счетов естественно присутствуют....

В какую сторону копать ?

Состояние: Консультация закрыта

Ответ # 230761 от Игорь К.

Здравствуйте, Black Monk!
Вы поменяли счет. В первом случае у счета 281 первое субконто "Сотрудники" и все работает.
Вероятно у счета 661 первое субконто другого вида. А Вы делаете выборку по субконто "Сотрудники".
Соответственно аналитика не подключается и попытка БиОле.ВыбратьСубконто(1) оканчивается неудачей.


Консультировал: Игорь К.
Дата отправки: 30.09.2008, 07:24

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 145410
Шахрайчук Владимир Анатольевич

# 1

= общий = | 30.09.2008, 22:54

А Вы не пробовали
ГлОлеБаза.глБИ.ИспользоватьСубконто(ГлОлеБаза.ВидыСубконто.Сотрудники);

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.17099 сек.

© 2001-2020, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.83 от 12.03.2020
Версия JS: 1.35 | Версия CSS: 3.37