30.09.2020, 04:50 [+3 UTC]
в нашей команде: 4 745 чел. | участники онлайн: 0 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.90 (14.08.2020)
JS-v.1.45 | CSS-v.3.39

Общие новости:
13.04.2020, 00:02

Форум:
29.09.2020, 17:36

Последний вопрос:
30.09.2020, 02:27
Всего: 152937

Последний ответ:
29.09.2020, 01:46
Всего: 260441

Последняя рассылка:
29.09.2020, 09:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
26.01.2012, 09:42 »
Вадим Исаев ака sir Henry
Про FAR это Вы мне хорошо напомнили, а то я, честно говоря, об этом уже забыл. [вопрос № 185293, ответ № 269749]
20.12.2011, 00:41 »
Николай Мироненко
Это как раз то, что я себе представлял! Спасибо Вам огромное за предоставленную помощь! smile [вопрос № 184781, ответ № 269218]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 144800
Раздел: [неизвестная рассылка]
Автор вопроса: Hasanovag
Отправлена: 23.09.2008, 20:54
Поступило ответов: 3

Здравствуйте товарищи программеры! Имеется вопрос по 1С 7.7.
Колонка "Элемент" таблицы значений имеет тип Справочник.

В Таблицу значений добавляю новую строку с помощью метода "ОткрытьПодбор()"

Далее как правило срабатывает:

Процедура ОбработкаПодбора(Элемент,КонтФормы)

ТаблицаЗначений.НоваяСтрока();
ТаблицаЗначений.Элемент = Элемент;

КонецПроцедуры
У меня подбором можно выбрать только элемент справочника...

Вопрос: Как заставить выбираться родителя и добавляться в тз?
Спасибо.

Состояние: Консультация закрыта

Ответ # 230071 от Provisor

Здравствуйте, Hasanovag!
Попробуйте перед вызовом "ОткрытьПодбор" вызвать метод "ВыборГруппы" с параметром 1.


Консультировал: Provisor
Дата отправки: 23.09.2008, 21:43

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 230121 от Strawberry

Здравствуйте, Hasanovag!
В модуле списка можно регулировать будут ли подбиратся группы, или только элементы. Для этого служит метод:

ВыборГруппы(<?>)
Синтаксис:
ВыборГруппы(<Режим>)
Назначение:
Устанавливает режим выборки групп для формы списка справочника, которая открыта в режиме выбора или подбора элемента. Возвращает текущее числовое значение режима выборки групп (на момент до исполнения метода).
Параметры:
<Режим> - необязательный параметр. Число: 1 - выбирать группы; 0 - не выбирать группы.
Замечание:
Метод доступен только в контексте Модуля формы списка справочника и относится только к текущему справочнику.


Консультировал: Strawberry
Дата отправки: 24.09.2008, 10:09

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 230124 от Gorus

Здравствуйте, Hasanovag!
Используйте метод ИспользоватьВладельца()

Приложение:


Консультировал: Gorus
Дата отправки: 24.09.2008, 11:14

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 144800
Астафьев Александр Николаевич

# 1

= общий = | 23.09.2008, 21:10

В каждом конфигураторе есть синтаксис помошник (это если у вас нет книг 1С 7.7) Если бы вы прочитали описание оператора "ОткрытьПодбор" то знали бы о флаге множественного выбора smile :
ОткрытьПодбор(<?>,,,,);
Синтаксис:
ОткрытьПодбор(<Объект>,<ИмяФормы>,<КонтекстФормы>,<ФлагМножВыбора>,<ТекЗнач>)
Назначение:
Открыть Форму подбора значений.
Параметры:
<Объект> - строка с именем объекта агрегатного типа для подбора. Можно указывать: ''Справочник.ХХХХХ'' или ''Документ.ХХХХХ'' или ''Журнал.ХХХХХ'' или ''Журнал.Подчиненные'' или ''ЖурналОпераций.ХХХХХ'', ''ПланСчетов.ХХХХХ'' (если ХХХХХ не задан, то открывается подбор из любого(всех) плана счетов) или ''Отчет.ХХХХХХ'' или ''Обработка.ХХХХХХ'', где ХХХХХ - имя вида соответствующего объекта, как он задан в конфигураторе.
<ИмяФормы> - строка с именем Формы подбора;
<КонтекстФормы> - необязательный параметр. Имя переменной, куда можно задать значение любого типа для передачи в открываемую форму. Данное значение будет доступно в открытой форме как атрибут Форма.Параметр. После исполнения данного метода система вернет в данную переменную контекст формы подбора. С помощью значения этого контекста можно затем произвольно манипулировать формой подбора, пока она открыта. Пока форма открыта, тип значения данного параметра равен 100 (см. ТипЗначения), если закрыта - 0.
<ФлагМножВыбора> - число: 1 - выбор нескольких значений; 0 - выбор одного значения, после чего окно закрывается;
<ТекЗнач> - необязательный параметр. В случае выбора из списка, здесь можно передать значение, на которое следует изначально установить курсор при открытии формы подбора.
Замечание:
Доступ к методу возможен только в контексте Модуля формы.

неизвестный

# 2

= общий = | 23.09.2008, 21:49

Внимательно читай вопрос студент:
Вопрос: Как заставить выбираться родителя и добавляться в тз?
Спасибо.

Т.е: Мне не нужен элемент справочника , а нужен родитель (папка) с элементами.
Можно конечно использовать метод ВыборГруппы(1) в модуле формы списка справочника,
а у меня внешняя обработка с обычной ТЗ, да и еще без возможности изменения конфигурации... smile

неизвестный

# 3

= общий = | 23.09.2008, 22:07

>>> Provisor, Можно по подробнее пожалуйста объяснить каким образом использовать метод ВыборГруппы?

Вот кусочек модуля:


Процедура ДобавитьСтрокуТЗ()
ОткрытьПодбор("Справочник.Номенклатура",,,0,);
КонецПроцедуры


Процедура ОбработкаПодбора(ВыбЭлемент,КонтФормы)

Если ВыбЭлемент.Вид()="Номенклатура" Тогда
ТабЭлементы.НоваяСтрока();
ТабЭлементы.Элемент = ВыбЭлемент;

КонецЕсли;
КонецПроцедуры


Процедура ПриОткрытии()

ТабЭлементы.НоваяКолонка("Элемент","Справочник.Номенклатура");

КонецПроцедуры

//ТабЭлементы - Таблица значений созданная на форме...
//ДобавитьСтрокуТЗ() срабатывает с кнопки на форме..

Шахрайчук Владимир Анатольевич

# 4

= общий = | 24.09.2008, 00:48

ТаблицаЗначений.НоваяСтрока();
ТаблицаЗначений.Элемент = Элемент;
ТаблицаЗначений.Родитель=Элемент.Родитель;

неизвестный

# 5

= общий = | 24.09.2008, 09:23

>>>Практикант

мне нужно чтоб родитель передовался в процедуру "ОбработкаПодбора"
мне элементы в принципе не нужны, только группы.
Спасибо Вам Владимир Анатольевич за ответ smile

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.23362 сек.

© 2001-2020, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.90 от 14.08.2020
Версия JS: 1.45 | Версия CSS: 3.39