12.11.2019, 21:36 [+3 UTC]
в нашей команде: 3 963 чел. | участники онлайн: 9 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.77 (31.05.2019)
JS-v.1.34 | CSS-v.3.35

Общие новости:
28.04.2019, 09:13

Форум:
04.11.2019, 16:30

Последний вопрос:
12.11.2019, 21:31
Всего: 150929

Последний ответ:
12.11.2019, 21:36
Всего: 259391

Последняя рассылка:
12.11.2019, 13:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
20.02.2012, 12:08 »
Даровко Антон Владимирович
Вы решили задачу отлично! [вопрос № 185468, ответ № 270006]
17.12.2009, 16:52 »
Николай // Programmator
Выбрал ON, все работает. Спасибо Вам! [вопрос № 175355, ответ № 257846]
21.09.2010, 14:44 »
Уманский Денис
Спасибо! smile [вопрос № 179976, ответ № 263116]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 144303
Раздел: [неизвестная рассылка]
Автор вопроса: Оксана/kasy
Отправлена: 18.09.2008, 14:53
Поступило ответов: 3

Подскажите пожалуйста как отправить из 1с 7.7 файл по электронной почте. Буду благодарна за пример кода.

Состояние: Консультация закрыта

Ответ # 229584 от Strawberry

Здравствуйте, Оксана/kasy!


Процедура ОтправитьПочту(КомуОтправить,ОтКогоОтправить,ТемаПисьма,ТекстПисьма,Вложение)
ЗагрузитьВнешнююКомпоненту("WheelAddIn.dll");
ВнКомпонент = СоздатьОбъект("AddIn.FWheelAddIn");

csFrom = СокрЛП(ОтКогоОтправить);
csTO = СокрЛП(КомуОтправить);
csSUBJECT = СокрЛП(ТемаПисьма);
csTEXT = ТекстПисьма;
Если ПустоеЗначение(Вложение) = 0 Тогда
csATTACH = СокрЛП(Вложение);
Иначе
csATTACH = "";
КонецЕсли;
Если ВнКомпонент.ОтправитьПочтуПоSMTP(MailServer, csFrom, csTO,,, csSUBJECT,csTEXT,csATTACH) = 1 Тогда
Сообщить("Электронная почта на адрес "+csTO+" отправлена!!!","!!");
Иначе
Сообщить(ВнКомпонент.ОшибкаПриОтпракеПочты());
КонецЕсли
КонецПроцедуры


ОтправитьПочту(БанкEMail,ОтКогоEMail,"Файл импорта ",,сКатал+сФайл);


Консультировал: Strawberry
Дата отправки: 18.09.2008, 15:25

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 229625 от DERL.KG

Здравствуйте, Оксана/kasy!
Я использую внешнюю компоненту ROM-Mail.dll. Данная компонента работает независимо как почтовый клиент, в отличии от встроенного который подгружает Аутлук.
код см в приложении
Удачи!

Приложение:


Консультировал: DERL.KG
Дата отправки: 19.09.2008, 07:34

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 229631 от Астафьев Александр Николаевич

Здравствуйте, Оксана/kasy! Работает на стандартной компоненте V7 1С Предприятие 7.7 Удачи smile

Приложение:


Консультировал: Астафьев Александр Николаевич
Дата отправки: 19.09.2008, 08:54

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.20126 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.77 от 31.05.2019
Версия JS: 1.34 | Версия CSS: 3.35