13.07.2020, 11:10 [+3 UTC]
в нашей команде: 4 666 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.89 (25.04.2020)
JS-v.1.45 | CSS-v.3.39

Общие новости:
13.04.2020, 00:02

Форум:
10.07.2020, 10:13

Последний вопрос:
12.07.2020, 13:06
Всего: 152733

Последний ответ:
12.07.2020, 22:25
Всего: 260326

Последняя рассылка:
12.07.2020, 14:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
15.08.2012, 23:47 »
Vilgelm
Спасибо за ответ. Всем участникам обсуждения так же огромное спасибо. [вопрос № 186522, ответ № 271411]
08.08.2013, 17:58 »
Ирра
Мне посчастливилось учиться у больших мстеров своего дела-лингвистов, но они говорили, что знать язык во всех нюансах не может никто. Но можно углубляться в определенных разделах. Спасибо, что помогаете разобраться в тонкостях (Фамилия Зима, Липа и тп). Но вижу и вопросы, которые есть в программе школы.(ССП и гостиная).
05.10.2009, 17:00 »
Teratoma
Это тоже хороший способ, спасибо. Но там надо вручную вводить еще и расширение файла, а для этого раскладку переключать... [вопрос № 172930, ответ № 255032]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 144303
Раздел: [неизвестная рассылка]
Автор вопроса: Оксана/kasy
Отправлена: 18.09.2008, 14:53
Поступило ответов: 3

Подскажите пожалуйста как отправить из 1с 7.7 файл по электронной почте. Буду благодарна за пример кода.

Состояние: Консультация закрыта

Ответ # 229584 от Strawberry

Здравствуйте, Оксана/kasy!


Процедура ОтправитьПочту(КомуОтправить,ОтКогоОтправить,ТемаПисьма,ТекстПисьма,Вложение)
ЗагрузитьВнешнююКомпоненту("WheelAddIn.dll");
ВнКомпонент = СоздатьОбъект("AddIn.FWheelAddIn");

csFrom = СокрЛП(ОтКогоОтправить);
csTO = СокрЛП(КомуОтправить);
csSUBJECT = СокрЛП(ТемаПисьма);
csTEXT = ТекстПисьма;
Если ПустоеЗначение(Вложение) = 0 Тогда
csATTACH = СокрЛП(Вложение);
Иначе
csATTACH = "";
КонецЕсли;
Если ВнКомпонент.ОтправитьПочтуПоSMTP(MailServer, csFrom, csTO,,, csSUBJECT,csTEXT,csATTACH) = 1 Тогда
Сообщить("Электронная почта на адрес "+csTO+" отправлена!!!","!!");
Иначе
Сообщить(ВнКомпонент.ОшибкаПриОтпракеПочты());
КонецЕсли
КонецПроцедуры


ОтправитьПочту(БанкEMail,ОтКогоEMail,"Файл импорта ",,сКатал+сФайл);


Консультировал: Strawberry
Дата отправки: 18.09.2008, 15:25

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 229625 от DERL.KG

Здравствуйте, Оксана/kasy!
Я использую внешнюю компоненту ROM-Mail.dll. Данная компонента работает независимо как почтовый клиент, в отличии от встроенного который подгружает Аутлук.
код см в приложении
Удачи!

Приложение:


Консультировал: DERL.KG
Дата отправки: 19.09.2008, 07:34

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 229631 от Астафьев Александр Николаевич

Здравствуйте, Оксана/kasy! Работает на стандартной компоненте V7 1С Предприятие 7.7 Удачи smile

Приложение:


Консультировал: Астафьев Александр Николаевич
Дата отправки: 19.09.2008, 08:54

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.20359 сек.

© 2001-2020, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.89 от 25.04.2020
Версия JS: 1.45 | Версия CSS: 3.39