19.02.2019, 19:14 [+3 UTC]
в нашей команде: 3 396 чел. | участники онлайн: 8 (рекорд: 21)

:: РЕГИСТРАЦИЯ

задать вопрос

все разделы

правила

новости

участники

доска почёта

форум

блоги

поиск

статистика

наш журнал

наши встречи

наша галерея

отзывы о нас

поддержка

руководство

Версия системы:
7.69 (10.02.2019)
JS-v.1.33 | CSS-v.3.35

Общие новости:
10.02.2019, 21:59

Форум:
16.02.2019, 15:03

Последний вопрос:
19.02.2019, 18:36
Всего: 148779

Последний ответ:
19.02.2019, 15:57
Всего: 257802

Последняя рассылка:
19.02.2019, 15:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
27.01.2012, 15:20 »
Петрович
Спасибо большое! Буду разбираться! Но по сравнению с bat-файлом как-то сложновато smile [вопрос № 185290, ответ № 269761]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 140991
Раздел: [неизвестная рассылка]
Автор вопроса: Provnick
Отправлена: 29.07.2008, 16:19
Поступило ответов: 1

Уважаемые эксперты, прошу помочь, Упр.Торговлей 8.1, макет накладной РеализацияТоваровУслуг, как можно сделать, чтоб распечатать на одной страничке несколько накладных, допустим 4, ИмяМакета, КоличествоЭкземпляров, необходимо еще какое то условие? "КоличествоЭкземпляров=4 ", так понимаю не идет, а как можно программно?

Состояние: Консультация закрыта

Ответ # 227037 от S-vet

Здравствуйте, Provnick!
ТабличныйДокумент (SpreadsheetDocument)
ЭкземпляровНаСтранице (PerPage)
Использование:
Чтение и запись.
Описание:
Тип: Число. Содержит количество страниц на листе при выводе табличного документа на печать. Допустимые значения: 1 - одна страница, 2 - две страницы, 0 - автоматическое определение.
Сериализуется.


Консультировал: S-vet
Дата отправки: 30.07.2008, 13:36

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 140991
неизвестный

# 1

= общий = | 31.07.2008, 11:57

//**********В синтаксисе вижу, а как применить?*****************
// Процедура осуществляет печать документа. Можно направить печать на
// экран или принтер, а также распечатать необходмое количество копий.
//
// Название макета печати передается в качестве параметра,
// по переданному названию находим имя макета в соответствии.
//
// Параметры:
// НазваниеМакета - строка, название макета.
//
Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт

Если ЭтоНовый() Тогда
Предупреждение("Документ можно распечатать только после его записи");
Возврат;
ИначеЕсли Не УправлениеПользователями.РазрешитьПечатьНепроведенныхДокументов(Проведен) Тогда
Предупреждение("Недостаточно полномочий для печати непроведенного документа!");
Возврат;
КонецЕсли;

Если Не РаботаСДиалогами.ПроверитьМодифицированность(ЭтотОбъект) Тогда
Возврат;
КонецЕсли;

Если ИмяМакета = "Чек" Тогда
Если НЕ ЗначениеЗаполнено(Организация) Тогда
Если НЕ ЗначениеЗаполнено(КассаККМ) Тогда
НачалоСообщенияОбОшибке = "Не выбрана касса ККМ."
Иначе
НачалоСообщенияОбОшибке = "У выбранной кассы ККМ не задана организация.";
КонецЕсли;

Предупреждение(НачалоСообщенияОбОшибке + Символы.ПС + "Печать чека невозможна.");
Возврат;
КонецЕсли;

// Получить экземпляр документа на печать.
ТабДокумент = ПечатьЧека();
ИначеЕсли ИмяМакета = "СерийныеНомера" Тогда
ТабДокумент = УчетСерийныхНомеров.ПечатьСерийныхНомеров(Ссылка, "Товары");
ИначеЕсли ИмяМакета = "РасходСРозничныхСкладовВЦенахАТТ" Тогда
ТабДокумент = ЗаполнениеДокументов.НапечататьПриходРасходСРозничныхСкладовВЦенахАТТ(Ссылка, мВалютаРегламентированногоУчета, Ложь);

ИначеЕсли ТипЗнч(ИмяМакета) = Тип("ДвоичныеДанные") Тогда

ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(Ссылка, ИмяМакета);

Если ТабДокумент = Неопределено Тогда

Возврат;

КонецЕсли;

КонецЕсли;

УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект, ЭтотОбъект.Метаданные().Представление()), Ссылка);

КонецПроцедуры // Печать()

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.67185 сек.

© 2001-2019, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.69 от 10.02.2019
Версия JS: 1.33 | Версия CSS: 3.35