19.11.2018, 11:20 [+3 UTC]
в нашей команде: 3 119 чел. | участники онлайн: 9 (рекорд: 19)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.55 (06.11.2018)

Общие новости:
24.09.2018, 16:49

Форум:
08.11.2018, 13:36

Последний вопрос:
19.11.2018, 09:04

Последний ответ:
19.11.2018, 08:36

Последняя рассылка:
19.11.2018, 09:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
17.01.2011, 18:20 »
Denis Loran
Просто и понятно [вопрос № 181921, ответ № 265480]
17.10.2016, 10:45 »
a.panin
Ого! Спасибо Вам огромное, всё работает. Отдельное спасибо за пояснения "для дураков", очень помогли. Если честно, думал обойдусь какой-нибудь простенькой формулой. [вопрос № 189879, ответ № 274151]
08.10.2010, 21:06 »
scoop
Большое спасибо за ответ и активную помощь! [вопрос № 180188, ответ № 263371]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 140991
Раздел: [неизвестная рассылка]
Автор вопроса: Provnick
Отправлена: 29.07.2008, 16:19
Поступило ответов: 1

Уважаемые эксперты, прошу помочь, Упр.Торговлей 8.1, макет накладной РеализацияТоваровУслуг, как можно сделать, чтоб распечатать на одной страничке несколько накладных, допустим 4, ИмяМакета, КоличествоЭкземпляров, необходимо еще какое то условие? "КоличествоЭкземпляров=4 ", так понимаю не идет, а как можно программно?

Состояние: Консультация закрыта

Ответ # 227037 от S-vet

Здравствуйте, Provnick!
ТабличныйДокумент (SpreadsheetDocument)
ЭкземпляровНаСтранице (PerPage)
Использование:
Чтение и запись.
Описание:
Тип: Число. Содержит количество страниц на листе при выводе табличного документа на печать. Допустимые значения: 1 - одна страница, 2 - две страницы, 0 - автоматическое определение.
Сериализуется.


Консультировал: S-vet
Дата отправки: 30.07.2008, 13:36

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Мини-форум консультации № 140991

Посетитель

ID: 218661

# 1

= общий = | 31.07.2008, 11:57 | цитировать цитировать  | профиль профиль  |  отправить письмо в личную почту пейджер

//**********В синтаксисе вижу, а как применить?*****************
// Процедура осуществляет печать документа. Можно направить печать на
// экран или принтер, а также распечатать необходмое количество копий.
//
// Название макета печати передается в качестве параметра,
// по переданному названию находим имя макета в соответствии.
//
// Параметры:
// НазваниеМакета - строка, название макета.
//
Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт

Если ЭтоНовый() Тогда
Предупреждение("Документ можно распечатать только после его записи");
Возврат;
ИначеЕсли Не УправлениеПользователями.РазрешитьПечатьНепроведенныхДокументов(Проведен) Тогда
Предупреждение("Недостаточно полномочий для печати непроведенного документа!");
Возврат;
КонецЕсли;

Если Не РаботаСДиалогами.ПроверитьМодифицированность(ЭтотОбъект) Тогда
Возврат;
КонецЕсли;

Если ИмяМакета = "Чек" Тогда
Если НЕ ЗначениеЗаполнено(Организация) Тогда
Если НЕ ЗначениеЗаполнено(КассаККМ) Тогда
НачалоСообщенияОбОшибке = "Не выбрана касса ККМ."
Иначе
НачалоСообщенияОбОшибке = "У выбранной кассы ККМ не задана организация.";
КонецЕсли;

Предупреждение(НачалоСообщенияОбОшибке + Символы.ПС + "Печать чека невозможна.");
Возврат;
КонецЕсли;

// Получить экземпляр документа на печать.
ТабДокумент = ПечатьЧека();
ИначеЕсли ИмяМакета = "СерийныеНомера" Тогда
ТабДокумент = УчетСерийныхНомеров.ПечатьСерийныхНомеров(Ссылка, "Товары");
ИначеЕсли ИмяМакета = "РасходСРозничныхСкладовВЦенахАТТ" Тогда
ТабДокумент = ЗаполнениеДокументов.НапечататьПриходРасходСРозничныхСкладовВЦенахАТТ(Ссылка, мВалютаРегламентированногоУчета, Ложь);

ИначеЕсли ТипЗнч(ИмяМакета) = Тип("ДвоичныеДанные") Тогда

ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(Ссылка, ИмяМакета);

Если ТабДокумент = Неопределено Тогда

Возврат;

КонецЕсли;

КонецЕсли;

УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект, ЭтотОбъект.Метаданные().Представление()), Ссылка);

КонецПроцедуры // Печать()

 

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.16509 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.55 от 06.11.2018