15.12.2017, 18:52 [+3 UTC]
в нашей команде: 2 382 чел. | участники онлайн: 10 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
15.12.2017, 18:17

Последний вопрос:
15.12.2017, 18:51

Последний ответ:
15.12.2017, 06:51

Последняя рассылка:
15.12.2017, 15:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
28.08.2011, 14:44 »
Алексеев Владимир Николаевич
Спасибо за конкретную помощь! Пошло движение вперёд! [вопрос № 183914, ответ № 268098]
21.11.2010, 20:06 »
Roman Chaplinsky / Химик CH
К сожалению, на вопрос о причинах различий морфемного состава слов эта констатация результатов ответа не даёт. [вопрос № 180840, ответ № 264178]
13.11.2010, 18:43 »
Посетитель - 342817
Все классно! [вопрос № 180719, ответ № 264000]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 138651
Раздел: [неизвестная рассылка]
Автор вопроса: Барилов Д.
Отправлена: 30.05.2008, 12:49
Поступило ответов: 6

Здравствуйте.
Помогите, пожалуста розобраться с проблемой. Суть такая. Последнее время стало много ушлых работников, которые за 1,5-2 часа до конца рабочего дня уходят и для того, чтобы создавать видимость типа "я только отлучился на минутку по неотложным делам, оставляют включённым комп. с запущенной 1С.
Ходить за ними выключать компы - не ice.
Для выключения компов по расписанию поставил соответсвующую прогу, но хотелось бы предварительно - во избежании всяких эксцессов с базой - закрывать 1С.

В конце процедуры ПриНачалеРаботыСистемы объявил функцию ОбработкаОжидания("ЗавершениеПоВремени",60);

Затем прописал саму функцию след. обр.

Функция ЗавершениеПоВремени()
Перем __Ч;
Перем __М;
Перем __С;
ТекущееВремя(__Ч,__М,__С);
Если (__Ч=19) И (__М<3) Тогда
Сообщить("Выключаем 1С. Всем спасибо за работу. До завтра! ");
ЗавершитьРаботуСистемы();
КонецЕсли;
КонецФункции // Завершение по времени

Но она почему-то не срабатывает.
Что я сделал не так?

Состояние: Консультация закрыта

Ответ # 224983 от Strawberry

Здравствуйте, Барилов Д.!
Попробуйте разместить ОбработкаОжидания("ЗавершениеПоВремени",60); в конце глобального модуля т.е. не в процедуре при начале работы системы а в самом теле глобального модуля, в той части где идет установка глобальных переменных.
ЗавершениеПоВремени() - вызывайте как процедуру см. синтаксис
Процедура ЗавершениеПоВремени()
Перем __Ч;
Перем __М;
Перем __С;
ТекущееВремя(__Ч,__М,__С);
Если (__Ч=19) И (__М<3) Тогда
Сообщить("Выключаем 1С. Всем спасибо за работу. До завтра! ");
ЗавершитьРаботуСистемы();
КонецЕсли;
КонецПроцедуры // Завершение по времени

Приложение:


Консультировал: Strawberry
Дата отправки: 30.05.2008, 13:21

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 224987 от Nikakoy

Здравствуйте, Барилов Д.!

скорее всего дело в вызове ЗавершитьРаботуСистемы() без параметра.
в этом случае идет запрос на сохранение документов.
Кроме того, в типовой ТиС есть реквизит справочника "Пользователи" "НеЗапрашиватьПодтверждениеПриВыходе" и в процедуре ПриЗавершенииРаботыСистемы() идет его проверка с повисанием вопроса "Завершить работу системы?". В кач-ве решения - объявить переменную "ОбязательноеЗавершениеРаботы" устанавливать в 1 при выполнении условия по времени, и не запрашивать подтверждение на выход при этом...

З.Ы. отлично работает такой вариант
Если текущееВремя()>"19:00:00" тогда


Консультировал: Nikakoy
Дата отправки: 30.05.2008, 13:37

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 224988 от Игорь К.

Здравствуйте, Барилов Д.!
Вариантов много.
Расскажу как сам сделал.
1.Завел Константу "Отключить" Число 5
2.Обработка которая включает/отключает режим отключения пользователей. Доступна только админу.
Там на форме поле ввода "Пауза" Число 3 - где вводится пауза в минутах до выключения.
и 2 кнопки ВКЛ и ВЫКЛ - включить/выключить таймер.
После включения В течение заданного интервала минут система выдает каждую минуту предупреждение, что осталось столько-то минут и когда время иссякнет выключает комп.
Процедуры висящие на кнопках ВКЛ и ВЫКЛ (Вкл() и Откл()) в приложении
В процедуре ПриНачалеРаботыСистемы()

Процедура ПриНачалеРаботыСистемы()
...

ОбработкаОжидания("ПоказВремени",60);
...

Запускаем раз в минуту обработку "ПоказВремени" .
Сама обработка в приложении
Она проверяет раз в минуту состояние константы "Отключить". и если там число отличное от нуля, сравнивает текущее время и время в константе.
После того как всех отключит и вы зайдете монопольно не забудьте в обработке нажать кнопку ВЫКЛ иначе она Вас через минуту тоже отключит.

Программа срабатывает не всегда.
1) если пользователь открыл модальное окно, то программно его не закрыть
2) если пока идет отсчет паузы кто-то зашел и начинает работать, то их тоже не выгоняет. Вероятно, что у них Константа.Отключить=0 и не обрабатывается.

Ну это только идея - доработайте под свои нужды

Приложение:


Консультировал: Игорь К.
Дата отправки: 30.05.2008, 13:41

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 225000 от Астафьев Александр Николаевич

Здравствуйте, Барилов Д.! Замениет условие на : Если (__Ч>=19) И (__М>3) Тогда.
Часы на разных компах идут по разному так что при вашем условии можно проскочить 3 минуты заветные и опять же время в обработке можно поставить больше 60 секунд т.е. меньше база будет нагружаться.
А вообще есть программы типа Remote Administrator(RAdmin), заходите на компьютер типа как в терминале только в сеанс пользователя и отключаете что вам нужно, и незачем бегать по кабинетам. А если вы это еще начальству поставите, чтоб оно начальство могло видеть чем сотрудники в рабочее время занимаются, то ваш рейтинг у руководства резко возрастет.


Консультировал: Астафьев Александр Николаевич
Дата отправки: 30.05.2008, 14:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 225037 от Владимир Лазурко

Здравствуйте, Барилов Д.!

Есть внешняя компонентка waiter, которая как раз для подобных целей разрабатывалась: считать время бездействия пользователя.

Эта компонента выдаёт время бездействия пользователя 1С, а уж как использовать полученную информацию, зависит от фантазии.

В Приложении ссылка на архив (200 Кб), в нём описание и пример использования.

С уважением, Владимир.

Приложение:


Консультировал: Владимир Лазурко
Дата отправки: 30.05.2008, 19:06

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Ответ # 225064 от Кулевский Сергей Владимирович

Здравствуйте, Барилов Д.!
Замените "ЗавершитьРаботуСистемы()" на "ПрекратитьРаботуСистемы()"


Консультировал: Кулевский Сергей Владимирович
Дата отправки: 31.05.2008, 01:10

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.16666 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн