16.01.2018, 12:52 [+3 UTC]
в нашей команде: 2 475 чел. | участники онлайн: 8 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.42 (30.12.2017)

Общие новости:
02.01.2018, 09:46

Форум:
12.01.2018, 10:25

Последний вопрос:
15.01.2018, 22:39

Последний ответ:
16.01.2018, 08:42

Последняя рассылка:
16.01.2018, 01:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
23.09.2010, 21:27 »
Кохан Владимир Иванович
Отлично! Все работает как нужно, большое спасибо [вопрос № 179999, ответ № 263156]
10.11.2011, 17:55 »
Олег
Огромное спасибо!!! [вопрос № 184405, ответ № 268700]
29.10.2009, 09:33 »
Sherinu
Большое спасибо, всё понятно! Портал и страна развиваются! [вопрос № 173781, ответ № 255985]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137575
Раздел: [неизвестная рассылка]
Автор вопроса: Extrbot
Отправлена: 19.05.2008, 22:44
Поступило ответов: 1

Добрый вечер! 1С 7.7. Есть оборотно-сальдовая ведомость. Бухгалтер по счету 77.2 или по любому другому счету формирует отчет. В ней видны кто клиенты по данному счету сумма и.т.д, но бухгалтеру нужно ИНН. В таблицу я добавил поле ИНН и как мне выдрать ИНН с контрагента или клиента? Все это она сохраняет в Excel и вручную набивает ИНН, что очень долго. Заранее спасибо

Состояние: Консультация закрыта

Ответ # 224167 от Астафьев Александр Николаевич

Здравствуйте, Extrbot! Полю "ИНН" ставите в свойстве тип "Выражение" и поле для выражения пишете ПечИнн().
В модуле создадите функцию:
Функция ПечИнн()
Если ТипЗначенияСтр(Ит.Субконто())="Справочник" Тогда
Если Ит.Субконто().Вид = "КонтрАгенты" Тогда
Возврат СокрЛП(Ит.Субконто().ИНН);
КонецЕсли;
КонецЕсли;
Возврат "";
КонецФункции
Пример я взял для бухгалтерии 1С7.7 редакция 4.5 "Оборотно сальдовая ведомость по счету". Предполагая что в соседнем поле где выводится наименование организации написано Ит.ПредставлениеСубконто(), если у вас в ячейке где выводится наименование контрагента или клиента стоит какая то другая переменная то в ПечИнн() вместо Ит.Субконто() нужно будет использовать соответственно другое значение.

Приложение:


Консультировал: Астафьев Александр Николаевич
Дата отправки: 20.05.2008, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.12701 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.42 от 30.12.2017