19.10.2017, 20:57 [+3 UTC]
в нашей команде: 2 183 чел. | участники онлайн: 3 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
19.10.2017, 15:04

Последний вопрос:
19.10.2017, 13:16

Последний ответ:
19.10.2017, 19:17

Последняя рассылка:
18.10.2017, 20:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
02.03.2010, 12:47 »
vera-nika
большое спасибо, вы мне очень помогли, сама я в этом не сильно разбираюсь [вопрос № 176985, ответ № 259824]
13.12.2010, 16:24 »
Detsle
Спасибо большое))) очень хорошо написал) Всё понятно! Выручил! [вопрос № 181294, ответ № 264718]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137575
Раздел: [неизвестная рассылка]
Автор вопроса: Extrbot
Отправлена: 19.05.2008, 22:44
Поступило ответов: 1

Добрый вечер! 1С 7.7. Есть оборотно-сальдовая ведомость. Бухгалтер по счету 77.2 или по любому другому счету формирует отчет. В ней видны кто клиенты по данному счету сумма и.т.д, но бухгалтеру нужно ИНН. В таблицу я добавил поле ИНН и как мне выдрать ИНН с контрагента или клиента? Все это она сохраняет в Excel и вручную набивает ИНН, что очень долго. Заранее спасибо

Состояние: Консультация закрыта

Ответ # 224167 от Астафьев Александр Николаевич

Здравствуйте, Extrbot! Полю "ИНН" ставите в свойстве тип "Выражение" и поле для выражения пишете ПечИнн().
В модуле создадите функцию:
Функция ПечИнн()
Если ТипЗначенияСтр(Ит.Субконто())="Справочник" Тогда
Если Ит.Субконто().Вид = "КонтрАгенты" Тогда
Возврат СокрЛП(Ит.Субконто().ИНН);
КонецЕсли;
КонецЕсли;
Возврат "";
КонецФункции
Пример я взял для бухгалтерии 1С7.7 редакция 4.5 "Оборотно сальдовая ведомость по счету". Предполагая что в соседнем поле где выводится наименование организации написано Ит.ПредставлениеСубконто(), если у вас в ячейке где выводится наименование контрагента или клиента стоит какая то другая переменная то в ПечИнн() вместо Ит.Субконто() нужно будет использовать соответственно другое значение.

Приложение:


Консультировал: Астафьев Александр Николаевич
Дата отправки: 20.05.2008, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13069 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн