25.04.2018, 07:47 [+3 UTC]
в нашей команде: 2 706 чел. | участники онлайн: 0 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.47 (16.04.2018)

Общие новости:
13.04.2018, 10:33

Форум:
23.04.2018, 20:08

Последний вопрос:
24.04.2018, 20:58

Последний ответ:
24.04.2018, 08:48

Последняя рассылка:
24.04.2018, 19:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
16.08.2009, 18:06 »
Бартосик Феликс Михайлович
Большое спасибо Лыскову Игорю Витальевичу и Стасу за их внимательное отношение к моим вопросам и правильные исчерпывающие ответы!
01.02.2011, 13:44 »
Кэр Лаэда
спасибо, продолжение беседы читайте в минифоруме [вопрос № 182078, ответ № 265684]
19.09.2009, 12:33 »
Dimon4ik
Спасибо! Именно то, что надо! [вопрос № 172312, ответ № 254363]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137575
Раздел: [неизвестная рассылка]
Автор вопроса: Extrbot
Отправлена: 19.05.2008, 22:44
Поступило ответов: 1

Добрый вечер! 1С 7.7. Есть оборотно-сальдовая ведомость. Бухгалтер по счету 77.2 или по любому другому счету формирует отчет. В ней видны кто клиенты по данному счету сумма и.т.д, но бухгалтеру нужно ИНН. В таблицу я добавил поле ИНН и как мне выдрать ИНН с контрагента или клиента? Все это она сохраняет в Excel и вручную набивает ИНН, что очень долго. Заранее спасибо

Состояние: Консультация закрыта

Ответ # 224167 от Астафьев Александр Николаевич

Здравствуйте, Extrbot! Полю "ИНН" ставите в свойстве тип "Выражение" и поле для выражения пишете ПечИнн().
В модуле создадите функцию:
Функция ПечИнн()
Если ТипЗначенияСтр(Ит.Субконто())="Справочник" Тогда
Если Ит.Субконто().Вид = "КонтрАгенты" Тогда
Возврат СокрЛП(Ит.Субконто().ИНН);
КонецЕсли;
КонецЕсли;
Возврат "";
КонецФункции
Пример я взял для бухгалтерии 1С7.7 редакция 4.5 "Оборотно сальдовая ведомость по счету". Предполагая что в соседнем поле где выводится наименование организации написано Ит.ПредставлениеСубконто(), если у вас в ячейке где выводится наименование контрагента или клиента стоит какая то другая переменная то в ПечИнн() вместо Ит.Субконто() нужно будет использовать соответственно другое значение.

Приложение:


Консультировал: Астафьев Александр Николаевич
Дата отправки: 20.05.2008, 08:23

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13189 сек.

© 2001-2018, Портал RFPRO.RU, Россия
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.47 от 16.04.2018