26.06.2017, 22:09 [+3 UTC]
в нашей команде: 2 046 чел. | участники онлайн: 4 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
26.06.2017, 21:10

Последний вопрос:
26.06.2017, 20:18

Последний ответ:
26.06.2017, 14:37

Последняя рассылка:
26.06.2017, 02:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
05.06.2010, 01:02 »
Talmingen
Грамотно! Так в компьютерных магазинах очень редко объясняют! Благодарю [вопрос № 178845, ответ № 261885]
13.11.2009, 17:40 »
popovaia
Спасибо! Просто спасли! [вопрос № 174180, ответ № 256452]
23.12.2009, 01:42 »
cebbep
Большое спасибо! Лектор принял и похвалил! [вопрос № 175461, ответ № 257978]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137057
Раздел: [неизвестная рассылка]
Автор вопроса: Ткаченко Алексей Васильевич
Отправлена: 16.05.2008, 11:57
Поступило ответов: 1

Добрый день. Уважаемые коллеги подскажите есть ли возможность программно перебрать все элементы на форме (кнопки, флажки, текстовые поля, списки и др.) если нет в этих элементах имени. Возможно есть вариант перебора по порядку обхода или другой способ. Все варианты интересны. Спасибо.

Состояние: Консультация закрыта

Ответ # 223776 от Сысоев Дмитрий Олегович

Здравствуйте, Ткаченко Алексей Васильевич!
Для Каждого Элемент из ЭлементыФормы Цикл
Если Элемент.Имя = "ОсновныеДействияФормы" Тогда
Кнопки = Элемент.Кнопки;
Для Каждого Кнопка из Кнопки Цикл
Если Не Кнопка.Имя = "ОсновныеДействияФормыЗакрыть" И Не Кнопка.Имя = "ОсновныеДействияФормыОК" Тогда //Это для панелей
Кнопка.Доступность = Ложь;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;


Консультировал: Сысоев Дмитрий Олегович
Дата отправки: 16.05.2008, 15:42

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13075 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн