16.12.2017, 11:55 [+3 UTC]
в нашей команде: 2 384 чел. | участники онлайн: 9 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
16.12.2017, 11:27

Последний вопрос:
15.12.2017, 21:02

Последний ответ:
16.12.2017, 11:06

Последняя рассылка:
15.12.2017, 21:15

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
25.09.2010, 11:17 »
Уманский Денис
Спасибки Вам smile [вопрос № 179975, ответ № 263139]
18.02.2010, 14:53 »
shader01
Спасибо, с этим все ясно. [вопрос № 176757, ответ № 259553]
22.09.2009, 22:36 »
Ирина П.
Огромное спасибо!!! Вы действительно ПРОФЕССИОНАЛЫ!!! [вопрос № 172450, ответ № 254534]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137057
Раздел: [неизвестная рассылка]
Автор вопроса: Ткаченко Алексей Васильевич
Отправлена: 16.05.2008, 11:57
Поступило ответов: 1

Добрый день. Уважаемые коллеги подскажите есть ли возможность программно перебрать все элементы на форме (кнопки, флажки, текстовые поля, списки и др.) если нет в этих элементах имени. Возможно есть вариант перебора по порядку обхода или другой способ. Все варианты интересны. Спасибо.

Состояние: Консультация закрыта

Ответ # 223776 от Сысоев Дмитрий Олегович

Здравствуйте, Ткаченко Алексей Васильевич!
Для Каждого Элемент из ЭлементыФормы Цикл
Если Элемент.Имя = "ОсновныеДействияФормы" Тогда
Кнопки = Элемент.Кнопки;
Для Каждого Кнопка из Кнопки Цикл
Если Не Кнопка.Имя = "ОсновныеДействияФормыЗакрыть" И Не Кнопка.Имя = "ОсновныеДействияФормыОК" Тогда //Это для панелей
Кнопка.Доступность = Ложь;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;


Консультировал: Сысоев Дмитрий Олегович
Дата отправки: 16.05.2008, 15:42

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.12994 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн