18.10.2017, 01:21 [+3 UTC]
в нашей команде: 2 177 чел. | участники онлайн: 1 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
17.10.2017, 23:14

Последний вопрос:
17.10.2017, 19:30

Последний ответ:
17.10.2017, 18:38

Последняя рассылка:
18.10.2017, 00:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
27.04.2011, 17:21 »
novij2011
Спасибо за быстрый ответ! ВЫ очень мне помогли. [вопрос № 182956, ответ № 266869]
10.10.2010, 22:17 »
Dimon4ik
Отлично! Сделал все до создания нового подключения, включительно, и Интернет заработал! Спасибо огромное! Хорошо выручили. [вопрос № 180254, ответ № 263424]
16.12.2010, 23:56 »
Марина
Спасибо Вам огромное! [вопрос № 181285, ответ № 264799]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137057
Раздел: [неизвестная рассылка]
Автор вопроса: Ткаченко Алексей Васильевич
Отправлена: 16.05.2008, 11:57
Поступило ответов: 1

Добрый день. Уважаемые коллеги подскажите есть ли возможность программно перебрать все элементы на форме (кнопки, флажки, текстовые поля, списки и др.) если нет в этих элементах имени. Возможно есть вариант перебора по порядку обхода или другой способ. Все варианты интересны. Спасибо.

Состояние: Консультация закрыта

Ответ # 223776 от Сысоев Дмитрий Олегович

Здравствуйте, Ткаченко Алексей Васильевич!
Для Каждого Элемент из ЭлементыФормы Цикл
Если Элемент.Имя = "ОсновныеДействияФормы" Тогда
Кнопки = Элемент.Кнопки;
Для Каждого Кнопка из Кнопки Цикл
Если Не Кнопка.Имя = "ОсновныеДействияФормыЗакрыть" И Не Кнопка.Имя = "ОсновныеДействияФормыОК" Тогда //Это для панелей
Кнопка.Доступность = Ложь;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;


Консультировал: Сысоев Дмитрий Олегович
Дата отправки: 16.05.2008, 15:42

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос

Время генерирования страницы: 0.13027 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн