28.03.2017, 11:07 [+3 UTC]
в нашей команде: 1 870 чел. | участники онлайн: 11 (рекорд: 21)

:: РЕГИСТРАЦИЯ

:: консультации

:: задать вопрос

:: все разделы

:: правила

:: новости

:: участники

:: доска почёта

:: форум

:: блоги

:: поиск

:: статистика

:: наш журнал

:: наши встречи

:: наша галерея

:: отзывы о нас

:: поддержка

:: руководство

Версия системы:
7.41 (25.02.2017)

Общие новости:
23.02.2017, 09:51

Форум:
26.03.2017, 18:27

Последний вопрос:
27.03.2017, 17:10

Последний ответ:
28.03.2017, 09:46

Последняя рассылка:
27.03.2017, 19:45

Писем в очереди:
0

Мы в соцсетях:

Наша кнопка:

RFpro.ru - здесь вам помогут!

Отзывы о нас:
22.06.2010, 23:54 »
Букреев Владимир Владимирович
Спасибо, очень помогло. [вопрос № 179194, ответ № 262236]
26.05.2010, 18:36 »
Петров Юрий Иванович
Спасибо огромное! Программа работает и написана отлично, все с комментариями) Похожий вопрос 155765 я видел и пробовал в нем разбираться, но алгоритма до конца не понял, пытался поменять шаг на 2, но не нашел где! И спасибо за подробное описание, буду разбираться) [вопрос № 178661, ответ № 261685]

РАЗДЕЛ [неизвестная рассылка]

[администратор рассылки: [неизвестный]]

Лучшие эксперты в этом разделе


Перейти к консультации №:
 

Консультация онлайн # 137057
Раздел: [неизвестная рассылка]
Автор вопроса: Ткаченко Алексей Васильевич
Отправлена: 16.05.2008, 11:57
Поступило ответов: 1

Добрый день. Уважаемые коллеги подскажите есть ли возможность программно перебрать все элементы на форме (кнопки, флажки, текстовые поля, списки и др.) если нет в этих элементах имени. Возможно есть вариант перебора по порядку обхода или другой способ. Все варианты интересны. Спасибо.

Состояние: Консультация закрыта

Ответ # 223776 от Сысоев Дмитрий Олегович

Здравствуйте, Ткаченко Алексей Васильевич!
Для Каждого Элемент из ЭлементыФормы Цикл
Если Элемент.Имя = "ОсновныеДействияФормы" Тогда
Кнопки = Элемент.Кнопки;
Для Каждого Кнопка из Кнопки Цикл
Если Не Кнопка.Имя = "ОсновныеДействияФормыЗакрыть" И Не Кнопка.Имя = "ОсновныеДействияФормыОК" Тогда //Это для панелей
Кнопка.Доступность = Ложь;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;


Консультировал: Сысоев Дмитрий Олегович
Дата отправки: 16.05.2008, 15:42

Рейтинг ответа:

0

[подробно]

Сообщение
модераторам

Отправлять сообщения
модераторам могут
только участники портала.
ВОЙТИ НА ПОРТАЛ »
регистрация »

Возможность оставлять сообщения в мини-форумах консультаций доступна только после входа в систему.
Воспользуйтесь кнопкой входа вверху страницы, если Вы зарегистрированы или пройдите простую процедуру регистрации на Портале.

Яндекс Rambler's Top100

главная страница | поддержка | задать вопрос | интересные статьи

Время генерирования страницы: 0.13434 сек.

© 2001-2017, Портал RFPRO.RU, Россия
Авторское право: ООО "Мастер-Эксперт Про"
Калашников О.А.  |  Гладенюк А.Г.
Версия системы: 7.41 от 25.02.2017
Бесплатные консультации онлайн